Blue flashing - followed by amber flashes and blue flash again

I can’t do anything with it… I configure it thru particle cli and I cant do anything after configuring wifi settings.

Amy hint?

Not really help for the description you mentioned :confused:

  • Which mode are you in?
  • Was it working before that?
  • What changed?
  • Which device are you using?
  • Blink blue or cyan?
  • Did you try SAFE mode?
1 Like

Reset mode

I’ve just flash it with a combined bin using the STK programmer … After listening mode and setup it goes into this mode…

Its a photon

Cyan flashes for a while… Then rapid cyan flashes for a second and then amber a couple of times and cyan again flashing…

Safe mode is not applicable since I can’t flash it… It’s no connecting to th cloud…

What changed… Well I am doing a project with solar panels… The power from the battery got too low I guess… And the photon refused to reset… So I had to ref lash it with a fresh bin. Provided by @Bdub in a similar event some days ago… (https://community.particle.io/t/is-my-photon-dead)

Hmm, not sure why you reprogrammed the Photon because of this, but it’s fixed now (I just waved a magic wand). If you reprogram your photon with that binary I gave you, it resets your keys.

Can you elaborate on what you tried after the battery got too low and the photon would not reset?

@BDub It’s now working. Thanks again for saving the night!

I reprogrammed it, because when the battery of the solar panel goes too low… The photon freezes… It has happened two times… I have been working hard to not let the code drain the Battery with deep sleep. But I have failed twice… Even in deep sleep the battery can be drained… This happens when in deep sleep by the way!.. And both times, renders the Photon useless… The photon, turns on it’s little blue led on… And it doesn’t reset or do anything at all… No matter what I do. Connect it to the computer USB port, power supply, press reset or any combination of mode attempts like safe mode… Nothing works… It only keeps the small blue led on. Nothing else responds.

So I thought that since the solution worked last time, it should work this time.

So… I think this will happen again if I let the battery drain… I will do my best not to let that happen, but I can’t promise I will succeed. So if it happens again. What should I do?

1 Like

Hmmmmm, well that’s definitely something I’ll be testing tomorrow morning :slight_smile:

If it happens again, you can reprogram with the binary… and then give me a shout with your device ID again and I’ll fix it up. Ideally we will soon figure out why this is happening and fix the issue.

Il keep you posted and try my best to gather as much info as possible…

Thanks!

When the photon is unresponsive again after a dead battery, please try disconnecting the photon from all power for 5 minutes, then reconnecting to USB power or a good power source. The 5 minute unpowered delay may help (and please let us know if it does!)

Ok it’s morning! :sun_with_face: I just tried to remove my Photon’s power while in deep sleep and it powers back up just fine when I reapply power. @frlobo could you share the exact code you are using? I think that will help us get to the root of the problem quicker.

This does not help. I have disconnect it from power for more than that. I will try it again if this happens.

Sure I can. When I go home il send it… I think… That when power goes down in deep sleep it’s not a sudden shutdown… Maybe I would simulate a discharged lipo? It holds voltage very well, but current drops… So I a, guessing that it does a series of reboots before running out of power. Or maybe it’s just my photon! :blush:

Il share the code later today.

I just tried with a variable power supply and dropped the voltage slowly while in deep sleep mode to 1V, then back up… on the way up it turns back on at about 1.9V on VIN. The RGB is only RED though, not WHITE because there is only enough voltage to bias the red segment. Code seems to run even at this low voltage (I’m in MANUAL mode) and the unit goes back to deep sleep. I tried a bunch of things with the power supply and the unit always seems to power up fine.

Il send the code in a bit…

I don’t know what else could it be… I have a spark fun battery shield, a weather shield in my setup.

@BDub Here is the code:

Happened again.

Here is more info of what happened. I will try the following in the lab to replicate it on the lab:

  • Deep Sleep it for 4 hours.
  • Slowly limiting the current & Voltage [Emulate dropout of a lipo].
  • Stay at a low level of voltage for a couple of hours.
  • Try to bring the power up again slowly.

Il let you know my findings.

Today I woke up to another small led Blue issue again. I don’t think it’s really power related anymore… The battery was at 30% when it happened. And I’ve tried powering another photon with the remaining power of the battery and it still going for about an hour now. So I now thing it’s related to sleeping issues. Maybe it’s the way I am invoking the deep_Sleep in my code or another hardware issue…

@BDub Can you wave that magic wand again. I am reprogramming again now.

@mdma I tried the five minute no power and then apply power with a good SUB source. No joy. I am posting the video of the power up after the five minute break.

https://vimeo.com/142802506

1 Like

Thanks for posting this. Can you still enter DFU mode?

We seem to have veered off course from the original intent of the thread. Could one of the Elites please factor this thread from the flashing orange to where the sleep issues start.

I can’t do anything with the photon without the stk programmer. I can re program it with the st-link tool. But it’s a hassle cause I need the magic wand thing!

In regards to DFU mode. What do you mean? I haven’t tried flashing using USB while noticing the blue led on. Do you think the photon is entering DFU mode without showing the mode in the RGB LED?

I agree on refactoring the thread…

With DFU mode, I’m wanting to determine if the bootloader is still ok.

Could you make a memory dump and send it to me please:

dfu-util -d 2b04:d006 -a 0 -s 0x8000000:0x100000 -U sleep_dump.bin

I think it’s too late, bacause I already reprogram it with jtag… I did a dump the first time a week ago or so and sent it to @BDub