I believe i bricked my photon


Currently using a photon for developing purposes. I am using windows 7 for programming the photon and sending my compiled .ino sketch to the photon. I wanted to try with a OS x operating system but i don’t have one. So i tried to install virtual machine and install a OS x variant, using bash i was able to install node.js and install the particle-cli! only issue is using atom when programming the device after setting the wifi config i upload a simple RGB test code and well, here we are. If i press the setup or reset button it does nothing, the computer doesn’t recognize the device plugged in and the led D7 is always active high. Any ideas of fixing it, don’t mind getting my hands dirty with smd soldering. :cold_sweat:

thank you, any suggestions would be appreciated.

Hi there

When you say the reset button does nothing, do you mean the LED doesn’t even blink off for a second?
Have you tried putting the device in safe mode? (Quick press reset while holding setup and then release setup when the LED starts flashing magenta).

1 Like

If Safe Mode doesn’t work either, you could try searching the forum for “dim blue” see if any of the suggestions there can heal your ill Photon :wink:


Thanks for the quick reply, the center led is not doing anything. As in it does not pulse, blink or even show a status led. I know the led should be blue, cyan or green but there is absolutely no lighting coming from the center led. Pressing and holding on buttons does nothing. Led D7 is always active high. Oh boy, hopefully i can fix it. It was working in virtual machine i got cyan pulse and i was uploading a code and the device reset to green to locate wifi and bam no status led after that.

i will try safe mode and see if i can get it back. also i will try to record and post the issue.

Can you get into dfu mode and flash tinker?