Can anyone help me recover my Photon?

I’ve got a Photon that I’ve used successfully for years, but I’ve had it off-line for a while, and just now tried to bring it back on-line. I put a new (VERY simple) app on it, and have not been able to get it to behave right at all. It will never go into the breathing cyan state. Instead it cycles through every imaginable sequence of LED colors. I’ve tried a factory reset and a couple other things I’ve found on-line. I’d love it if someone could help me put it back in factory fresh mode.

Thanks.

Hi @spork -

I will try to assist. Are you able to get it into either:

  • Safe Mode
  • DFU Mode

Regards, Friedl.

1 Like

Thanks very much! Yes, I just now put it in DFU mode and flashed the Tinker app onto it (via the CLI) to verify.

But no luck putting it in Safe mode

Interesting point…
If I ping it from the console it sometimes says that the device in “on-line and connected” and a few seconds later it will say it can’t be reached. But it never does get into the breathing cyan mode. It does seem to just continuously go through every possible combination of colors and flashes.

@spork -

It this even after flashing Tinker app?

If so, I would recommend following the steps in this post:

Let me know.

Regards, Friedl.

1 Like

Yes.

Hmmm… unfortunately I get stuck at this step…
“You may update to 2.0.0-rc.1 directly first, flash the system firmware (attached above)…”

I don’t see any firmware “attached above”. :frowning:

@spork -

Are you following these steps??

  1. Download the four files below form Github. Make sure to download both Part1 and Part2 for photon firmware.
  2. Install and update Particle CLI on you computer
  3. On OSx… open Terminal (or CLI in workbench)
  4. Connect device to you USB port
  5. Make sure devices is in DFU mode (flashing yellow)
  6. In terminal type: particle flash --usb and then simply drag the downloaded files into the terminal (one by one) window. It will automatically enter te file name and path. The device should remain in DFU mode after each flash, unlike Particle Doctor.
  7. Hit Enter. When done, repeat with the next file, in this order:
  • photon-system-part1@1.5.bin
  • photon-system-part2@1.5.bin
  • photon-bootloader@1.5.0+lto.bin
  • photon-tinker@1.5.0.bin
1 Like

Yes, trying to follow those steps, but I can’t find the four files referenced in step 1.

@spork -

The are on the page if you scroll down a bit. See image;

Of course there are newer versions of device OS, I juist dont have the link. Should be easy to find on GutHub, or start with these, you can update afterwards :wink:

1 Like

D’OH! Sorry about that. I’ve got them downloaded now, but it’s 3am so I’ll have to take it up tomorrow.

Thanks again.

haha… all good! let me know.

OK, I just tried flashing the four files. The first two went fine. When I tried to flash the bootloader I got this message:

“Error writing firmware…unknown module function 2, use --force to override”

I didn’t try the “–force” option because I didn’t want to risk flashing the wrong thing before checking with you.

I unplugged it and plugged it back in to see whether it would go on-line - despite not yet having the bootloader or tinker app. It doesn’t currently show up in my device manager, and the LED quickly goes to a constant white (not flashing) mode.

I can’t ping it.

Check this thread, it deals with a similar problem.

1 Like

Thanks. But I just went ahead and configured it to my home wifi network - and that worked!? So I went into the console on my laptop and flashed Tinker - and that worked!?

So it currently seems to actually be working perfectly (which makes me very happy and appreciative). Do I still need to try to flash the bootloader anyway?

1 Like

You can find that out by putting your device into Listening Mode (blinking blue) and then run particle serial inspect.

2 Likes

Thanks. It looks good from what I can see. Here’s the bootloader portion…

Bootloader module #0 - version 400, main location, 16384 bytes max size
Integrity: PASS
Address Range: PASS
Platform: PASS
Dependencies: PASS

1 Like

Hi @spork -

Glad to hear it is seemingly working :slight_smile:

FYI and in my experience… you can --force to override if it is not working properly yet. Also update the device OS. If all goes smoothly, I recon you are good to go :wink:

Regards,
Friedl.

1 Like

Thanks so much! I was ready to give up on it.

1 Like

The problem with --force is that you can also forcefully flash an incompatible binary and that will definitely not help your course.
But when you have the correct binary --force will not be required :wink:

One possible reason for being unable to flash the bootloader binary may have been that the previous version did not support DFU flashing for that.
In older versions you needed to flash the bootloader via Listening Mode and particle flash --serial

2 Likes

damnnnnn… haha. Seems I have bene lucky so far :rofl: