B523 LTE Cat 1 Setup Failed and now stuck

B523 arrived with SoM Evaluation board today. Just tried to get it online using the Particle App and the experience was fine until the App appeared to hang on connecting via cellular to the internet/cloud. The bluetooth connection dropped and now it is in a loop of trying to connect to the cellular network but the App trying to connect Bluetooth. It is also telling me that it can’t connect to a mesh network - I didn’t ask for it to join a mesh. So basically stuck. I haven’t had this sort of issue Borons. Very disappointing

[Update] LED was flashing green, pressed and held Mode button to make the LED flash blue, restarted setup and got through to the step where it said Paired with device via bluetooth. I then had to wait about a minute until anything changed on the App, the remainder of the setup process worked. The difference in my tenth attempt was that I moved the device to a place with a strong 4G signal, my office has a marginal 4G signal mostly it is 3G. So much for LTE Cat1 with backup 3G capability - can I ask the obvious, has this been field tested in Europe? Both the Boron and Electron I have work fine in the same spot.