Intermittently unable to connect to cellular, even in Safe Mode

Hello there!

I have several Boron LTE boards that seem prone to dropping cellular connection. Usually when they drop, a simple reset brings them back up, but not always. In these cases where a reset does not fix the issue, I have to wait (sometimes several hours) before the board will come online again. Antennas are connected securely and I live in a large urban area in FL with plenty of cell coverage.

I’ve tried different antennas as well as putting the devices in safe mode to rule out issues with my code. They still won’t connect. Any ideas on a solve? Or is this out of my control (cell tower maintenance, etc)? It seems to be happening too frequently (every week or so) to be cell towers, but maybe that sort of maintenance happens more frequently than I thought. Any help is much appreciated.

1 Like

Thanks for posting – we can definitely help you understand what is going on (Device OS bug, cell tower issue, firmware issue) and help with a fix.

If you DM @mstanley or @ParticleD with your ICCID, we can start to do some investigation.

1 Like

Thanks for getting back to me. I tried DMing them and it says “Sorry, you cannot send a personal message to that user.”

@afast, if you DM me, I can forward it for you.

It won’t let me send it to you either. It’s seems I’m cursed today lol

A new user likely needs to make a minimum number of posts before he/she can send private messages.
That’s a common feature for discourse forums I believe, for spam bots.

@afast, I just elevated your status. You can try your DMs again.

1 Like

That did it. Sent a message with my ICCID and further info to @mstanley and @ParticleD. Thanks for your help guys.

1 Like

I have received his DM, and will take a look at things later today (or it might be @mstanley, but one way or the other we’ll take a look).


Hey @afast, I also received your message. Thanks for reaching out. I did a lookup on for this particular ICCID and its associated device ID.

That I can tell, I’m seeing a large number of retry attempts from our cloud service that eventually lead to timeouts. This indicates to me that it’s dropping a lot of packets of data, which seems to suggest either weak connectivity or potentially too much data for the bandwidth available.

One thing I would recommend is looking into running boron-clouddebug on one of these devices so that we can get some more in depth info readout.

Are these devices using their provided antenna? Are they in an area that is blocking (inside of a building) or outside/near a window?

Thanks for looking into it! I will start looking into clouddebug right away.

The data we’re sending is pretty small. Definitely smaller than the standard diagnostics update/vitals query that you can get on the console.

These devices are using the original antenna indoors near a set of large windows. I’m in downtown Orlando, FL, so there’s a few tall buildings around but not many and LTE coverage here is usually really good.

Hey @afast . That’s fantastic info. Thanks!

Since the amount of info you are sending is small, that seems to suggest to me that it may, in fact, be something to do with session reinitialization or handshake. The Particle session payload can be a bit larger than the typical data transmission. Do you notice that it takes a little while to connect on startup? (Flashing cyan for a while).

In terms coverage–LTE CAT-M1 is actually not the same as LTE. They are different technologies that have separate coverage, so LTE coverage may not necessarily imply just as good CAT-M1 LTE. I would expect fair coverage all throughout Orlando though for both.

For reference, for the Boron LTE at this time, AT&T is the current carrier we use for Boron LTE’s cellular connectivity.

Usually it takes about 10-12 seconds to connect, but most of it is flashing green. Once it gets a connection, it flashes cyan for all of maybe 0.5-1 second. At least right now, since it’s come back online. Earlier it would never get to cyan.