Argon won't reconnect to wifi after reboot or flash

I’ve seen some older threads with similar issues, but it was said the issue should be addressed in the next RC.

Argon Device OS 1.4.4

Using my iPhone to connect the Argon to the local wifi, it works all ok. After updating some code and flashing it, the Argon ends up flashing green, and never connects back to wifi. Holding the Mode button to get the blue flashing light, I then can use my iPhone to configure the wifi again, but that returns invalid wifi password.

I reset the wireless access point, and reconfigure wifi on the Argon again, and it works.

But every time I reboot / flash the device, the light flashes green, I need to do the same dance each time.

I’ve tried a few different access points, (Netgear Nighthawks) with the same result. Netgear Nighthawk’s have latest firmware available.

The AP’s use WPA2-Personal. Other devices like laptops have no issues in connecting to the AP’s.

It was previously connect to a different access point, but since moving, I’ve had these issues.

Any ideas on why it’s not reconnecting after a reboot?


Have you tried clearing all stored WiFi creds on the device?
The Argon stores up to 10 previous sets of WiFi credentials which may be tried before finding the correct one and it may be that it gets stuck in the process.

Thanks for the tip ScruffR. Yeah I held the SETUP as per until the light blinks blue quickly, then used the app to configure wifi again. It connected OK, but after removing power, and plugging it back in, it still flashes green.

While it’s flashing green, I can reboot the access point, and then the Argon reconnects to wifi.

I’ll try from a different branded access point to compare.

Good, one box checked! :white_check_mark:

Some more questions

  • What code are you running?
  • What SYSTEM_MODE()?

I don’t specify a system_mode or system_thread in my code.

When it’s connected to wifi, I can use the iPhone Particle app to flash Tinker, and on reboot, the green light flashes. Same as when I run my code.(very basic code).

When I bring the Argon home to where it was first connected, it still flashes green until I reconfigure wifi for this access point. After rebooting or flashing it, the Argon ALWAYS reconnects to wifi.

So far I’ve confirmed:

  • Wifi reconnects using Ubiquiti access point. (First AP it was ever connected to)
  • Wifi does NOT reconnect when using Netgear Nighthawk (tried multiple units)

No other devices have issues connecting to the Nighthawks. It’s not running out of IP’s to allocate, as in some tests it was the only device connected.

I’ll try another branded access point or just hotspot with phone.

It’s looking like it’s an issue with the Netgear Nighthawk access points, but I don’t know why that would be an issue, as it does connect the first time. For reference, this is the access point:

Can you restrict the channel width on your AP to 20MHz (disabling 40MHz)?

I remember reading about issues with wide bandwith.

Unfortunately there doesn’t seem to be any channel width settings. The Nighthawk is a 4G Mobile hotspot that provides wifi. There’s not many other settings that can be changed besides 2.4GHz/5Ghz bands. It’s using a simple SSID name and password. No special chars.

Connecting it against my iPhone hostpot works, and reconnects fine. So I’d say it’s something specific to that AP. Luckily I was just using these as a temporary thing.

1 Like