Argon: can't detect serial device

I have an Argon that is functioning and can cloud flash, but whenever I open the Serial Monitor, it only says

Polling for available serial device...

I tried factory resetting the Argon, and I have the same problem. Using the CLI, I can detect the Argon via USB, but not Serial.

PS F:\xxxx> particle usb list
dev5 [xxxxxx] (Argon)

PS F:\xxxx> particle serial list
No devices available via serial

I have also updated Workbench and verified that the Serial Monitor works just fine with a different Argon. I have also verified there are no other Serial Monitors open.

This problem has come up with a few of my students as well. Is there a fix for this or something else to try?


@Support can you please take a look?

1 Like

Hi @rob7!

I'm Alberto, from the TAM team.

I think you are using Windows. Can you check the Device Manager and see if the device is listed under "Ports (COM&LPT)"? You can plug and unplug it in to see any changes in the list. If not, check if the device is listed under "Other devices".

1 Like

Hi @jalbersr !

Thanks for following up. Yes, I'm on Windows 10. When I plug in this device, it shows up under "Other" with the label Argon Serial (COM16)

That Argon is associated with the wrong Windows serial driver.

It's a little bit of a pain to fix, but you can fix it with the instructions for repairing Windows 10 serial drivers.


Thank you @rickkas7 ! That worked perfectly!

One followup question:
Is there a reason driver issue occurs (so I could prevent students from having the problem in the first place)?

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.