Argon serial and cdc

argonserial

Unlike my photon and thingdev I do not get a serial port when I connect the argon usb.

I get an argon cdc hardware device (see attached pic)

what is the cdc? how do I get a virtual com port when i plug in the argon?

Thanks

I guess this is not Windows 10, is it?

With anything before that you’d need to install drivers. Currently the Particle drivers that “recognise” the new devices are being tested but you can work around by use of zadig to install a USB CDC driver for the CDC devices (this can also be used to install libusbK for DFU Mode).

LMGTFY : https://en.wikipedia.org/wiki/USB_communications_device_class

Nope not windows 10 yet. I have so many projects for work and play I have not been able to interrupt my app building (60 + scientific instrument interfaces from companies like Bruker Honeywell Draeger… ) that still use libs that could cause issues with windows 10.

So I haven’t updated.

But thanks for the info. I’ll read up on it and see about windows 10 or the driver.

Btw, the first thing anyone should do with photon,xenon,argon is get the serial working - its the best way to debug.

Hey @ScruffR,

Any alternative for Mac? These modules are not mounting to the dev directory on my Mac. Is there a driver I need for this? I really can’t live without the CLI.

I’m not a Mac guy, but as I understand it Linux and Mac already have the required drivers on-board (most recent versions of MacOS may be different according to what I’ve read not long ago).

But unlike Gen2 devices Gen3 devices don’t expose USB Serial by default.

Hmmmm… I’ve got an Argon connected to my Mac over USB and it’s in listening mode(brand new module). It’s not coming up in the Dev directory. I’ll look into it.

Factory new devices don’t expose USB CDC. It will only appear after you’ve flashed 0.8.0-rc.25 or later and call Serial.begin() or use listening mode.

1 Like

Thanks @rickkas7, I just figured that out :slight_smile: I went through the claiming process on my phone and noticed it magically appeared in the /dev directory. I wonder if using dfu-util to update the module would work? I’d have to get a new module out of the box to know for sure. CLI is absolutely mandatory for us. We currently use Photon modules and sometimes I have to flash 100 of them at a time. I’m NOT going to do that without the CLI.

Yes you can flash a device OS 0.8.0-rc.25 or later to a device by USB DFU to get the USB CDC to work.

However, there is an important caveat: You still need to go through mobile setup on the Argon once at this time. The reason is that the NCP (network coprocessor, the ESP32) needs a firmware upgrade as well, and this cannot be done easily over USB at this time. The mobile apps do it over BLE.

Update. Just use windows 10. I plugged the argon into a windows 10 and the com port worked perfect.

Thanks

Turns out, upgrading the NCP is easier than I thought.

For the Argon, if you are upgrading a factory unit without using the mobile app, you must manually apply the NCP (network coprocessor) update as well. Go to the Argon NCP Release Page and download argon-ncp-firmware-0.0.5-ota.bin. With the Argon in blinking blue (listening mode):

particle flash --serial argon-ncp-firmware-0.0.5-ota.bin

You may get the error “Error writing firmware: TimeoutError: timed out after 10000ms” but this is normal if the Argon is still blinking magenta rapidly. Let it sit for a minute and then it should reboot and be updated.

Note that this must be done in --serial mode not --dfu. The mobile app does this automatically, so this step isn’t required in normal circumstances. Also, the NCP binary does not need to be updated for every system firmware version. At this time, only factory new devices need an update.

2 Likes

I am having the same issue of not getting the Argon or Xenon drivers running Win7 64 bit. I tried the zadig link, but the site seemed to be down. I’ll try again tomorrow. Any word on when (if) these are going to become available?