No /dev/tty.usbmodem* device appearing in MacOS 10.14

I have a brand new argon plugged into my Mac running 10.14. particle serial waits indefinitely looking for a serial device. It looks like these devices are supposed to be named /dev/tty.usbmodem*, but no relevant device is showing up on my Mac. The argon shows up in lsusb (installed via homebrew).

$ particle serial monitor --follow
Polling for available serial device...
^C
$ ls /dev/tty.usb*
ls: /dev/tty.usb*: No such file or directory
$ lsusb
...
Bus 020 Device 000: ID 2b04:c00c 2b04 Argon CDC Mode  Serial: e00fce686234def07e33c022

Is there another package or driver I need to install?

Hi Rohan,

Have you run the device through the app setup? Some Argon devices do not have their Serial enabled until the DeviceOS is updated via the app for the first time.

All but the most recent of Argon shipments have a version of Device OS that does not support CDC (USB serial) mode. Doing a mobile setup or in DFU mode (blinking yellow):

particle update

will update it and allow for USB serial mode to work.

I tried particle update with no success. With my Argon already blinking yellow:

$ particle update

!!! I was unable to detect any devices in DFU mode...

> Your device will blink yellow when in DFU mode.
> If your device is not blinking yellow, please:

1) Press and hold both the RESET/RST and MODE/SETUP buttons simultaneously.

2) Release only the RESET/RST button while continuing to hold the MODE/SETUP button.

3) Release the MODE/SETUP button once the device begins to blink yellow.

I previously tried using Visual Studio -> Particle: Flash firmware and update, which also failed.

Thanks,

-rohan

Have you run the device through the app setup? Some Argon devices do not have their Serial enabled until the DeviceOS is updated via the app for the first time.

Yes, I am running Device OS 1.4.4 and the device is “breathing cyan”.

I found the problem. There was a USB device still showing up with the same Bus and device number as the Argon, which had been unplugged weeks ago. After a hard reboot everything working as expected.

1 Like

That’s an odd problem to have :upside_down_face: Glad you got it sorted!

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.