[ISSUE] MacOS: dfu-util cannot see the particle device

Hello,

This is my first post here. (I’m new to Particle)
I’ve tried to find answers to my issue, unsuccessfully.

I’ve setup the Workbench & VS on my mac (10.14) and I can cloud compile and could flash my project on my Argon (1.5.0).

I’m trying to use the debugger cable but the dfu-util command cannot connect to the argon :

  • debugger board led is lightened.
  • there is a new file named /dev/tty.usbmodem14302 when I plug the cable into the usb port.
  • but when I try to local flash I got the following error :
    :::: PUTTING DEVICE INTO DFU MODE
    Unable to connect to the device unum_argon. Make sure the device is connected to the host computer via USB
    make: [dfu] Error 1 (ignored)

I cannot find out where to set the usb information ( /dev/tty.usbmodem14302) in the settings.

Any help would be appreciated.

Thank you.

Take care,

Johan

I have a Mac OS setup with Workbench, but the way I execute DFU commands is by using the command line in a standard terminal. I’m also using direct USB, not JTAG so factor that in… To use DFU on Mac in this way you’d need to make sure you have the Particle CLI installed. Instructions here:

https://docs.particle.io/tutorials/developer-tools/cli/

This should attempt to install dfu-util. Confirm by running the following in a terminal:

dfu-util -l

More info here: https://support.particle.io/hc/en-us/articles/360039251394-Installing-DFU-util

Since you can see /dev/tty.usbmodem14302 you have hardware connectivity. The device now needs to be in DFU mode. Instructions here:
https://docs.particle.io/tutorials/device-os/led/argon/
----Summary----
To enter DFU Mode:

  1. Hold down BOTH buttons
  2. Release only the RESET button, while holding down the MODE button.
  3. Wait for the LED to start flashing yellow (it will flash magenta first)
  4. Release the MODE button

With DFU mode enabled and a hardware connection ready with dfu-util you should be able to run DFU commands. For example flashing core firmware “particle flash --usb <system-part.bin>”…

Can someone else speak to JTAG unique steps or the Workbench side?

Welcome to the community.

To confirm exactly what you want to do;

  1. You have configured the device (with device OS 1.5.0, selected Argon and input the device name or ESC)
  2. You have locally compiled with no errors or warnings
  3. You have locally flashed (via USB cable) to the device successfully

You now have the Argon still connected by USB cable AND the debugger board connected to the mac with the cable correctly connected between the debugger board and the ARGON?

And you have followed the tutorial instructions?

https://docs.particle.io/tutorials/developer-tools/workbench/#debugging-3rd-generation-

:point_up: solid advice

also, are you running linux? if so, you’ll need to install the udev rules:

  1. run the Particle: Launch CLI command (docs)
  2. run particle usb configure in the terminal instance that launches (docs)
  3. connect your device and run particle usb list

it should show your device… if it does, re-try your flash by running Particle: Flash application & Device OS (local)

if not, the info listed here would help further troubleshoot:

Thank you all for the responses and the welcome.

Issue is fixed : I missed the fact that a second usb port must be plugged in …