How to output to Serial Port Monitor?

Good evening all, very new user. New to mesh, arduino, and the community and I could use some help.

I’ve got a Particle Argon connected to a BMP180 temp/pressure sensor. The Argon is setup, “breathing blue” and the sketch has been uploaded.

Where I’m stuck is the output bit. The sketch is outputting values to the serial monitor, but I can’t manage to figure out how to view the it on the Argon?

What I’ve tried:

  • CLI will only connect when in Listening Mode correct? To my knowledge this means that my sketch isn’t running?
  • The Particle Docs page only mentions getting the Argon ID using PuTTY, again in Listening Mode.

Chances are I’m either googling the wrong term, or missing something entirely.
Any suggestions?

Your sketch normally doesn’t run while in listening mode.

When your sketch is running and you have called Serial.begin() in setup() and the argon is printing to serial you should be able to connect to the serial port using Particle CLI (or any compatible serial program).

The following command should work:

particle serial monitor
1 Like

I guess you mean “breathing cyan”, right?

Nope, as @nrobinson2000 already mentioned CLI features a serial monitor via

particle serial monitor --follow

(the --follow switch is for auto reconnect when the port gets closed and reopened, especially helpful for Windows)

4 Likes

Hey @nrobinson2000, thanks for taking the time to help me out. That’s the command I had tried in the past. However today when I ran “particle serial monitor” in command line, it returned: "particle-cli v1.35.2 Upgrade now by running ‘npm install -g particle-cli’ ".

Unfortunately when this is run I get: ‘npm’ is not recognized as an internal or external command, operable program or batch file.

Rerunning “particle serial monitor” returns “No serial port identification” in bold red text.
After downloading the CLI installer again, I get the same result: “No serial port identification”.

I can reboot the Argon and the console will confirm handshake.

Where to next?

@ScruffR
Yes, you are correct. I meant breathing cyan, not blue. Whoops!

You did not yet state what PC operating system… Windows, Linux, Mac? If using Windows, run the full CLI installer again… I would not use the npm method because it doesn’t update the windows drivers, and resolve the dependency issues (I think?), if needed.

I had issues with getting the Argon to recognize on Serial as well. I ended up applying the USB Serial driver using the Zadig utility as recommended by @ScruffR in this post… that recommendation was before RC27 so I’m not sure if the driver installation is more solid now. Again, if Windows, check your Device Manager and look for “Argon CDC” or equivalent with an exclamation.

2 Likes

@ninjatill

Running W8.1
Re-ran the CLI installer - no change
Downloaded Zadig, installed all 4 options - no change
While the Argon is connected, inside Device Manager:
image
I connected various other items to all USB ports, and they all worked on all ports.

When your device is in Listening Mode or your application calls Serial.begin() you should see the Argon under the COM port category and not under Universal Serial Bus controllers.
So showing us this section doesn’t prove nor deny anything :wink:

You should not install all 4 options, but only the one correct one for the respective mode.
USB Serial (CDC) for Listening Mode and Serial
libusbK for DFU Mode

Your device has to be in the respective mode in order to install the correct driver.

2 Likes

Oh dear.

So I had a lightbulb moment. I went back to a Trinket I was using a few weeks ago for funsies, to try and get the COM port category to even display inside Device Manager, again no luck.

I tried a different cord and BINGO, now stuff works. Are there multiple types of Micro USB cables? The only visual indicator that the two cords are different are that the micro usb connection is 1/8" longer.

Solution may have been a combination of any of the above in the thread, but the final change was using a different cable.

You mean micro USB?
There are cables for charging only, without the data lines, but the Particle cables are all fully connected.

Yep, meant micro USB…edited the post. I was not using the cables out of the Argon box, but rather a random cable that was nearest.

Not all cables have data lines on them. Some are just power. If a device is not being detected, always try to check and make sure it has data connectivity.

1 Like

I had never run into that before, now I know!