Serial communication Problem for argon

All of a sudden no data is getting printed by Serial PORT. I don’t know and not able to make out why the Serial port of my USB cable is not working while I can upload code from workbench using Serial Communication , but no data is getting print on terminal screen when write code for simple print data

Does your device show up under Ports in Device Manager?
Could it be that the device got a different port number assigned by the system?
Can you try particle serial monitor --follow to see whether CLI can find the port?

2 Likes

When doing Serial list it shows my device
But when i do Serial monitor, it does not echo back and after that, I am not able to write any command and have to shut the window to write commands again, and also still not printing data …

i am not able to make out this behavior, because if the Serial port is damaged of the argon as it is not printing data then how it is able to configure it via Serial port.

Also another thing want to ask, Do Wifi and BLE use same RF circuit because my argon shoes either of these two errors when i try to reflash my device after flashing the code which uses BLE and WIFI both:
1) Device not discoverable or is offline and
2) Device is running debug firmware which does not support OTA. Reflash Device OS using Workbench or CLI (particle update).

Or what can be reasons for showing this error on flashing it via WEB IDE.

What color is the RGB led on the device when you are trying to interact via serial?

If the RGB is not breathing cyan, the argon is not connected to the cloud.

If you do not have SYSTEM_THREAD(ENABLED); in your program the device will only run the application (setup/loop) when it is connected to the cloud (breathing cyan).

To enable the system thread and have the device run your application regardless of cloud connection, add SYSTEM_THREAD(ENABLED); to your code.

More information about system thread here:
https://docs.particle.io/reference/device-os/firmware/argon/#system-thread

RGB is blinking Cyan when i am trying to interact via Serial, and in Console, it shows unreachable to cloud but it is breathing CYAN which as per the documentation means it is connected to cloud.
But in actual
1) it is not Publishing any Data to cloud When I flash theBLE+WiFi code And shows above mentioned 2 errors on flashing device again .
**2) it is not printing anything on the Serial Monitor(The USB PORT), whatever code I flash on the device **

And it always shows CYAN color breathing.

P.S: Issue of Serial Monitor, not printing Data has raised all of sudden, I tried my same code last week and it runs perfectly but now when I try, it shows this behaviour.

Can you post your complete code here? (Not screenshot)

It could help find the cause of the problem.

```cpp
// Your code
```

Hey BLE+WiFi problem is solved but Serial port is still not working

You should still post your code, as @nrobinson2000 mentioned above.