Argon / i cant send the code using serial


please see the attached pictures, my Argon was working perfect till i tried to send another code using usb serial , i noticed it send the file using particle flash --serial …bin

“fake” but in the cmd doesn’t say successful so i found its still with the old code, so i decided to do particle doctor but again it does update the firm ware but then i cant proceed further as you can see from the attachment. could you help please?
it still hanging now with red-blue-white colour.

Thank you

I’d rather use --usb in DFU Mode as --serial doesn’t seem to ever report failure to work. Even with a binary that is not compatible with the device or even a useless text file.

For a proper log of the process add the -v (verbose) switch

particle flash --usb <yourFirmware.bin> -v

BTW, you can use particle binary inspect <yourFirmware.bin> to check whether your binary is actually meant for Argon.

Also Device Doctor is not for such cases :wink:

Do you mean magenta?

If so, your device is in Safe Mode and requires a Device OS upgrade.

I suggest you run these commands (in DFU Mode)

particle flash --usb tinker -v
particle update -v

Then rebuild your firmware for Argon with 2.2.0 as the Device OS target and flash OTA or via USB.

1 Like

Thank you, yes it was magenta and now fixed it by using you suggestion by using particle flash --usb tinker -v and i did update it as well, however i still struggling to send the code by using usb,

i tried
particle flash --usb sms1.bin -v
Error writing firmware: Incorrect platform id (expected 12, parsed 13), use --force to override
VError: Error writing firmware: Incorrect platform id (expected 12, parsed 13), use --force to override

i also tried --force

attempting to flash firmware to your device sms1.bin
Failed to flash sms1.bin: The access token provided is invalid.

That is exactly what I expected, you have not built that binary for Argon (platform ID 12) but for Boron (platform ID 13) and that cannot work.

Hence, DO NOT use --force to force an incompatible firmware into a device that cannot deal with it!
Good job the access token issue prevented you from doing that.

That’s the reason why I explicitly said

Have you tried what I also suggested

1 Like

yes i used --usb in DFU Mode and cannot flash the firmware and i used particle binary check and says : CRC is ok (dca3180e)
Compiled for boron
This is an application module number 1 at version 6
It depends on a system module number 1 at version 2008

done it with rebuilding the firmware with 2.2.0 as you suggested and it says flash successful, but it blinks magenta after flashing cyan for seconds

1 Like

working :slight_smile: thank you very much @ScruffR

1 Like