Argon can't connect through app


#41

Unfortunately, this is a mesh network, and hence there is no option to name the 2.4/5 GHz different, nor is there to turn one off.

Although I wonder - if the Argon is communicating on a 2.4GHz radio, surely on would think the router would be smart enough to keep it on a 2.4GHz channel rather than try to connect it to a 5GHz one.


#42

So using an borrowed iPhone to setup the argon (Android doesn’t work), and creating a 2.5Ghz network with no IPv6 and a non-empty alphanumeric password I am getting stuck at the point that the device wants to connect to the network. It whines that the password is incorrect. Well, I have a bone dead simple password on this network and I’ve connected to that network using other devices. I am new to the particle so I am a little unclear as to what options I have. Is the app method of setting these up just DOA and I should hook up a serial port and try to get them setup and configured using the CLI? Is there a way to configure them over USB or BT that doesn’t involve the app?


#43

For another IoT thing a year ago I split my home WiFi into two different SSIDs with different frequencies and different names. That was just cheap LED sting controllers. Obviously that did not help with the Argon so I am guessing it is a protocol issue. If others on the thread try splitting their networks please let me know the outcome. I will not be able to test a phone hotspot workaround until tomorrow. The current project will eventually be installed (if it ever works) at a research facility where I will not be able to alter the WiFi network much.


#44

Right now the only way to set up a mesh is via the mobile apps (and yes, the Android app has issues on certain devices; this is being worked on). Eventually I expect you’ll be able to do it via the CLI. I’m hoping for something like

particle mesh create <gateway_deviceid> <meshname>
particle mesh add <deviceid> <meshname>

and so on.


#45

Hello,

I’ve got 3 Argon Kits and with all I have the same issue as mentioned in this post. After update of the firmware, the BT connection is lost, the device blinks green very fast. After hard reset it’s still the same issue.

While switching over to the ethernet featherwing I still encounter the same issue, BT is disconnecting during setup.

Any thoughts on hot to connect?

Regards, V.


#46

What kind of mobile device/OS version are you using?


#47

I’m using Apple iPhone and iPad Pro with IOS 12.1. On both devices the same problem.
Tried these devices:

  • ARGON
  • BORON

Regards, V.


#48

If I connect via the USB serial setup wifi I get it to fast blink green but it doesn’t go cyan. I am guessing that is why the app thinks the password is bad. Using the m command the device mac is 00:00:00:00:00:00 which looks broken. Does that command show a mac normally?


#49

There was an Android app upgrade last night that took me from timing out on joining the WiFi network to hanging. This is closer to what I see if I serial into my argon. Maybe this update helps others.


#50

Found unsatisfactory workaround for the network issues. I have an android phone. I disconnected it from the my home WiFi and started a wifi hot spot through the phone. I was able to select that network during the setup of the Argon and it successfully established an cloud connection. I can’t leave my phone in the field so this will not work in real life. My home WiFi is IPv6 comparability problem. I would really like to go through my LinkSys router.


#51

Hi, I had the same issue until I found this post:

I deactivated IPv6 on my router and voila! all my problems went away :trumpet:

PS: oh, I see it’s been mentioned here above already:


#52

I just tried disabling IPv6 on my router but still could not get connected. perhaps there was some element of IP6v on my router. I am back on my phone wifi hotspot and hope the patch can push out to my argon soon.


#53

I just wanted to give an update to my situation, as it relates to this topic.

My Argon will not connect to my home wifi using the ios app - it always results in rapid green blinking. It will connect to my iPhone’s Personal Hotspot wifi, resulting in breathing cyan, and I can publish events et. al. only when it is connected to my phone acting as a hotspot.

My home wifi is a TP-Link Deco M5 mesh network. It has both 5GHz and 2.4GHz networks both using the same SSID and credentials. IPv6 is disabled. The password is “Abcdefghi1”. When trying to connect to this network as is, after selecting my network from the ios app, the Argon switches to rapid green blinking, the ios app tells me the bluetooth connection was lost, and I need to do a factory reset on the Argon to get it back to blue blinking listening mode.

I added a guest network on my home wifi and turned off the 5GHz, so it is 2.4GHz only. It has a different SSID then my regular network, and the password is (was) “abcdefgh”. IPv6 is still disabled, and the Argon is unable to connect to this network either. Same results as before.

So I am unable to connect to my home wifi using the ios app.


#54

Just recently @avtolstoy has pinpointed an issue I had from the beginning which finally has boiled down to my router providing more than two possible DNS servers.
If yours does too, rc.26 should have a fix for that.

I was just going to delete the third DNS that was stored in my router to check whether that’s a workaround till rc.26 gets released.


Update:
After removing the third DNS entry from my router my Argon connects to my WiFi.


#55

Evidence in my network supports this issue with >2 dns servers.

Not all other things are equal, but I was able to set up a less complex (and consequently less protected) testing network. One difference is a single dns server compared to more than 2 on my production network.

All mesh devices connect happily to the network with a single dns server while failing to connect to the network with more than 2 dns servers.


#56

I confirm, can’t able to connect Argon to local WiFi network when the password of SSID use special caracter. I try to another SSID with only letter caracters and worked.


#57

Hi guys,
I have the same issue I can’t connet any of my argon (2) on my wifi 2.4, password contain only letters and numbers, IPV6 is off. I had 3 DNS I removed one and still can’t connect. I tried with my iphone 8 and galaxy s9.

I ran out of thing to try…

On my s9 on the first boot I selected xenon instead of the argon and the app pushed the firmware update…can this be the source of the problem?

In other words, is the first firmware update is the same for argon/xeno/ argon ?


#58

It’s the same updating process for all mesh devices, but the binaries are different. I think that the updater checks to make sure the .bin file is the correct one for the target device, but I’m not positive.

@wod One thing you could try is to install the CLI tool, download the Argon rc.25 binary, put the device into DFU mode, and at a command prompt, enter

particle flash --usb system-part1-0.8.0-rc.25-argon.bin

Then, try going through the setup process again using your mobile device.


#59

@particleD Thanks for the suggestion.

I flashed the system-part1-0.8.0-rc.25-argon.bin and still can’t connect wifi

I also tried to flash
particle flash --usb argon-ncp-firmware-0.0.5-factory.bin --force

And I get
dfu-util: Last page at 0x0019e6ff is not writeable


#60

I think the NCP update wants to be applied via particle flash --serial and you should use this binary
https://github.com/particle-iot/argon-ncp-firmware/releases/download/v0.0.5/argon-ncp-firmware-0.0.5-ota.bin

However, rc.25 has still got issues that may prevent you from connecting to WiFi for various reasons. rc.26 has solved a lot of these.