Argon instability issues

I just received my 8 Argons.

Argon 1: initial setup seemed to go well, but then the rainbow didn’t work. Visible as online in Tinker app. Setting D7 to digitalwrite crashed the Argon. Reboot restored Argon as online, but setting D7 to digitalwrite keeps crashing Argon. When Argon is not powered on, it shows up as online in WebIDE and Console. After several minutes Argon starts flashing green rapidly. I flashed a simple led on/off sketch, this works initially but after a few minutes Argon flashing green rapidly and going offline, even though as showing online in Console and IDE.

Argon 2: exactly the same story. Basically another dead Argon. Argon always showing as online in the cloud, but it isn’t. Run Diagnostics gives an error.

Argon 3: initial setup went fine and rainbow working. led firmware flashed and operational. However, leaving it overnight, Argon goes offline, even though led breathing blue. Reboot will restore functionality.

BLE: I was expecting normal BLE functionality out of the box as advertised (WiFi + Mesh + Bluetooth), but it looks like we have to wait for this.

My photons are working well and are stable, but this only started happening in firmware 8.

So far not impressed with Argon and afraid to test the other Argons in the box.

I have not yet tried the Xenon, wanting a stable Argon first.

No one else seems to have these problems, judging from the Forum.


There’s an ongoing issue with a particular router --> Mesh: issue with certain? Xfinity routers

Thanks for flagging that. I saw that in the Forum before I posted. I am using an Airport Express network (Apple). And the issue does not seem to affect all Argons.

I will try some more and report back.

Argons also seem to be having issues obtaining DHCP leases from Microsoft DHCP servers.

Quite a few people have reported similar issues, myself included, just have to search a little. I’m not familiar with apple equipment, other than to say most everything is locked tight. If possible, turn off all IPV6 routing.

Here is an update.

I created a new wireless network, not using any Apple components.

I set up three more Argons using that network. Initially it looked OK, as Tinker worked without a flaw.

However, after a couple of hours, all three Argons were offline, just like with the Apple network.

Any suggestions on how to troubleshoot this will be highly appreciated. I have several projects that need these Argons urgently!

I similarly had a Xenon mysteriously disconnect from the Mesh spontaneously in the middle of the night. Had to hard power cycle to get it to connect again. Unstable is right.

I’m having a similar problem. Just setup my first Argon via Android, it went through the setup process and seem to get stuck downloading updates but restarting the process allowed it to finish successfully. I then set up a network for it and finally I setup a new Xenon, no issues with either. I let it sit there for awhile and I noticed he Argon crashes, does an SOS and reboots every 2 to 3 min. The Xenon is doing a fast green blinking almost all the time. I thought maybe the Xenon was causing the issue before when I unplugged it the Argon continues to crash repeatedly. Oddly the ‘Device Vitals’ show the Xenon has tons of disconnection events while the Argon has none. Firmware for both is 0.8.0-rc.25.

I also tried flashing the ‘Blink’ example and it runs and blinks the led a bit before an SOS and a reboot, just like before. It flashes red seven times after the SOS which is listed as ‘Exit’ in the Photon docs.

No issues with my 6 photons so I figure this is a firmware or device issue and will await for updates. Just wanted to make it known you aren’t the only one with issues, though for me, the diagnostics function works and shows no issues.

Hey folks – just wanted to jump into this thread to let you know that we’ve released v080-rc.26 which contains a bunch of fixes that improve the setup process, Mesh stability, and range between devices.

Among them is a fix which should improve compatibility issues with IPv4/IPv6 routers that result in Xenons and Argons getting stuck in “blinking green” mode.

Instructions for updating to rc.26 are available here – would love to hear your feedback!

1 Like