Mesh: issue with certain? Xfinity routers

I reported a similar issue with Cisco EPC3925 cable modem weeks ago - good to know a fix is in the works.
As temporary workaround I just inserted another router (e.g. Netgear WRT824) that didn’t try to force IPv6 despite my ISP not supporting it.


I tried that with a Linksys/DD-WRT router, but apparently its DNS is in pass-through mode (at the time I didn’t know enough to know to turn that off).

1 Like

Even with rc.25 I’ve not got any luck directly connecting.
@ParticleD, have you had any chance to test rc.25 with your previously not working setup?

I’ve submitted some logs of my device to @jberi, but they don’t reveal a lot. Maybe Particle could provide some more verbose device OS with additional debugging outputs for the connection process.

This morning I confirmed that rc.25 does not have the fix in it. So I guess we’ll have to wait for rc.26. I don’t know what the sked is for that though.

I have the same problem. Xenon can’t connect to cloud, blinks green Argon connects to the cloud, but Xenon as endpoint through Argon does not connect to the cloud, it blinks green. I have a Comcast Xfinity X1 router, their brand. I’ve tried Xenon as gateway using the ethernet featherwing. That gateway Xenon connects to the cloud, but alas, another Xenon as mesh endpoint does not connect to the cloud with Xenon as gateway. I’m using an iMac OS Mojave, and an iPhone 7S.

I already mentioned this in another thread that I started, but on suggestion from @ParticleD, I put another router in between my Xfinity modem(Arris) and the xenon ethernet gateway, and the connection issues disappears.

Not a fix, but a good enough workaround for me currently.


Note that the “in between” router needs to serve up DNS – that’s the whole point of doing it. My Linksys/DD-WRT router (which is what I used) does not do that by default – it passes DNS requests up to the main router.

I had some truly bizarre stuff happening on Saturday when I added a new laptop to my network. The “in between” router was set up as 192.168.1.x, and the Arris is set up for 10.0.0.x. Somehow the laptop grabbed as the DNS server, rather than the Arris. The result was that the laptop could resolve IPV6 addresses, but not IPV4. That took a while to figure out… I mention this just in case anyone else has weird network issues when they have an “in between” router on their LAN.

BTW I cannot figure out a way to disable IPV6 in the Xfinity/Arris modem…

Not sure about DNS vs. DHCP.
My “intermediate” router does still use my providers DNS but acts as DHCP for its subnet the Argon can join.

Interesting. I heard internally that it was a DNS thing.

It might be, it’s just my semi-educated guess that DHCP might be at least involved :wink:

I’m almost certain it’s this. @rickkas7 linked me that in another thread, so I fired up wireshark and saw nd6 packets. When I killed the source of the nd6 packets, the problems stopped. In my case, the nd6 packets were being sent out by odhcpd running on an openwrt access point.

As far as I understand it: the nd6 packets contain wrong/bad DNS settings, and the mesh device blindly accepts it as fact & overwrites those that were obtained via ipv4 dhcp.


So, I guess I shouldn’t wait up for my Xenon to finish joining my network? Three (3) tries on each of three (3) different Xenons, similar results:

Quick flash green on the Xenon, breathing cyan on my Argon but I’ve also seen fast cyan on the Xenon with breathing cyan on my Argon.

Router = Xfinity Cisco DPC3939, phone Samsung-SM-G930A.

That’s interesting, when I was having the problem, my endpoint Xenon would always get past the adding Xenon to mesh network step, but would hang on Starting a secure session with the Particle cloud via Gateway step.

I have no idea what that tells us, but it looks different than my issue.


Try a non Samsung phone.

I used a iPad pro 11 to setup everything since my Samsung Note 9 was having issues during setup.

Thanks, @jimbol & @RWB. Unfortunately, we might not have the device here I’ll need to get this to work. I tried my wife’s iPhone 7 but no luck. I then tried to see if I could use my old Motorola Droid but that would only allow me to load Particle v2.2.2 instead of the current v2.3.5. I also tried my Samsung SM T377A tablet but the camera won’t focus on the tiny sticker. We’ve pulled out the iPad Air to see if that might work but we’re trying to get it updated first. I’m not holding out a lot of hope.

As a side note, I will say that the Particle instructions for the Apple are much clearer than for the Android. I know this is early on but I’m hoping the programmers at Particle are paying more attention than the people writing the tutorials. When I read things like this in the quickstart guide: “As such, when you go to compile source code, it’s a good idea to verify that the board you” What? The sentence just stops leaving the person hanging, much like my Xenon is leaving me hanging.

Well, my wife’s iPad Air (iOS12.1) at least gets me to the “starting a secure session with the Particle cloud via Gateway” but stops there. I’ve exhausted our resources; we have no more phones, iPads, or tablets to try. I guess I’ll wait for some patches to come out!

I’m not overly concerned as I have no real need for this stuff, I just purchased it for the learning experience. I will say, however, that it doesn’t seem to have been very well tested before launch. My Argon seems to be doing relatively well but even that is giving me the following warning on my console: “The device is disconnecting from the Particle Cloud too frequently. Large numbers of cloud disconnects are often caused by poor signal strength or network congestion. If possible, move the device to a place with better Cellular signal.” Assuming that’s a typo and they’re talking about WiFi, my Argon is sitting literally 24 inches (60 cm) above my router!

1 Like

Thanks (all) for notes about cases that are not working.

For what it’s worth (who’s keeping track?), I’ve got the Ubiquity “Amplifi” home router, using Comcast as ISP, and the initial (Spectra 2018 hardware kit) Xenon pair and Etherwing work well together. DHCP is issuing IPv4 locally. I don’t know if IPv6 is being issued…

1 Like

That is the same problem I am having. It connects to the wifi once during setup, then after about 30 seconds, it begins searching for the internet, never to connect again. I have an Xfinity router, also.

Please fix this soon!

1 Like

This problem also impacts ASUS RT-AC88U routers. The XENON will briefly flash cyan after the setup in sync with the Argon (gateway), and then suddenly change to flashing green fast. The workaround is to disable IPV6 in the ASUS router and then setup the XENON devices again.