Argon can't connect through app


#21

Just to be sure that I am not communicating something vague :slight_smile: --> https://github.com/particle-iot/firmware/pull/1604


#22

@robie1373 Does your WiFi password contain any of these characters: ,, ", \? As mentioned by @kennethlimcp, there’s a known issue with Argons being unable to connect to a WiFi network if its SSID or password contains certain characters. If that’s not the case, would it be possible for you to flash a firmware binary that has the debug logging enabled to your device, then capture the logs via the hardware serial?


#23

The device reset worked. I am still stuck on the argon connection to the particle cloud. It sounds like others may be having the same problem. It may just be a newby problem. I can pair the phone and Argon, I can add my local network ID and password. I get a “connected” message on the phone to say the argon has a network connection. Then however the Argon hangs on getting the cloud link. The phone locks on the connection screen with the compass rose spinning for half an hour. The Argon blinks green fast and then green slow I assume while it is trying to connect. Is there perhaps a WEP security issue? While the phone says “connected” maybe it can’t reach to the cloud.I have tied both connecting the argon as WiFi and as Mesh. I now am assuming mesh is a wrong choice. I should note as well that I have no special characters in my password for my LAN but my cloud account has a “)”. I will try changing tonight when I get back to the Argon Board.


#24

Today I registered 3 Argons on a wifi network with a different password, containing only alphabetic characters and it worked very well!

Thanks for the tip and looking forward to being able to connect to networks with special characters.

Also the registration of the 10 Xenons worked very well via BT. Congratulations to the Particle team for their good job in creating this process!!!

On the other hand, I am NOT impressed with the maximum distance between nodes of a mesh network!
It was my hope to solve the connectivity issues I am experiencing with my network of 10 Photons…

So, I tried out many indoor situations today with my network of one Argon and 10 Xenons and one wall is enough to break the connection! But I guess I should post this worry in another thread…

:thinking:


#25

Believe I’m having the same issue.
I’m trying to connect my first Argon using the mobile app. I get the blinking green then fast blinking green and it cycles that way indefinitely. No special characters in my SSID or pwd. Tried a few factory resets but no dice.

I was really looking forward to trying these out as replacements for the photons in my project but I’ve quickly lost confidence.


#26

I got an Argon to set up with no issues. Got excited!

I’m having a similar issue with Xenon - the message after “congrats…” is a “Something went wrong with Bluetooth. Please restart the set up process and try again.”

I’ve started over several times, restarted my iPhone (iOS 12.1). I’ve turned off and on Bluetooth.

I tried the factory reset - it blinked yellow for a couple minutes. How long should it go? It would not respond to the left button. I clicked the right button, it stopped flashing yellow, started blinking blue. Tried again, same error.


#27

@sergey my wifi password is alphanum only. I will work on getting some logs when I get back home. One of the reasons I like particle devices is I can (generally) hack without a faffing about with a bunch of janky usb serial BS. /oldmanrant.


#28

Nope, in this case it’s a xenon, and just trying to add the device before even adding it to the argon gateway


#29

There is definitely an issue with the iPhone or ios or split-band wifi networks. I tried my new Argon several times with the same results as noted above - it gets all the way to entering my credentials, then an error pops up that the bluetooth is lost, and the Argon goes to rapid flashing green. I need to go to factory reset and start over (with the same results every time).

However, after turning off the phone wifi and using its hotspot instead of my home wifi, it connects fine.

I have a TP-Link Deco M5, which creates a 2.4/5GHz network. My SSID is all alphanumeric, and my password is like Abcdefghi1. Any other things to try to get it to join my home network?


#30

I’m a newbie, so I’ll look up how to do the flash, and give it a try.


#31

Hello everyone. I’m iOS developer at Particle. The Argon issue described in this thread sounds to me like a firmware issue, but I can’t confirm that just yet. What I know for sure is that the only time iOS app may drop connection is in ‘setup complete’ screen (after offering to add one more device to same mesh network). Any other connection drops are initiated from hardware side. Furthermore, @MrHofflich mentioned that he is seeing same issue on both iOS and Android devices which suggests that problem is definitely outside of mobile app.

Right now I am working on adding support for log sharing in iOS app. Next app release will include some minor UX improvements and new service screen (accessible by tapping ‘device list’ screen title 10 times) that will contain debug information for most recent app sessions that will be easy to share via email/airdrop. This won’t access device logs, but at least we will be able to see more insights in what is happening in the app which I hope will help us investigate some of these issues we are unable to reproduce in our environment. I assume this update will go live sometime towards middle of next week.


#32

@robie1373 Thanks. Please note that the logs may contain sensitive info, such as your WiFi password, so you may want to change it before sharing the logs


#33

Thanks, for the iOS app what I did noticed is that after entering the credentials for the wifi, the argon started to flash green like trying to connect, but then in the app showed the error message shown in the original post, that did not happened in the android app (which I don’t know if the iOS is correct and the android is not), in other topics, the problem is attributed to a problem with IPv6 problem in the firmware. What I had to do in order to have it working is to deactivate the IPv6 from my connection, then use my laptop as a hotspot and connect through that. After that everything worked like a charm.


Argon Setup Failure
#34

This is very valuable information. Not sure how well IPv6 is handled on firmware side (I think @sergey will comment on that when he sees this), but I have just checked that there was missing check for IPv6 address in iOS app. That missing check does not result in a error message, but app would fail to recognise device getting connected if it would (if device would start breathing cyan). Adding this right away and will ship it with next build.


#35

Cool!! So glad I could help! Finally can give a little bit back to you guys! You are doing an amazing job! Keep it up!


#36

This is a known issue (https://github.com/particle-iot/firmware/pull/1596) that is already fixed in our development branch (mesh-develop) and is slated to be included in the next release quite soon.


#37

Well, changing the password for one without special characters did not work either. I changed one other thing and did not connect for mesh but WiFi only. That produces a slightly different infinite loop with slow green blinking lights, followed by fast green lights and then a long white LED. The long white is new. Progress? I don’t know. I’ll try a different Argon tomorrow. Still have high hopes that this will work. I need to put a bunch of sensors in a test place to see if I can use these for a class. Right now I think this blink pattern might look really nice on a Christmas tree if ai had a dozen in this blinking cycle.


#38

Very frustrating !!! You need to setup a pinned thread that says that your products CANNOT be setup on a network with IPv6 until you release an update to your firmware. I have got to rant here, what cave network are you guys on? The world is on IPv6 as well as IPv4 now, if you want to be successful as an IoT company you have got to do better and get current! Not testing on an IPv6 network is a basic mistake that should not be made.

And when is ‘quite soon’? You need to put a date on it. Not being able to setup the product is not a small problem that can casually put off till ‘quite soon’.

Come on folks, do better if you want to be successful!


#39

In my case, I’m pretty sure the issue is that the Argon can’t connect to my home WiFi, due to the fact that the 2.4ghz and 5ghz networks are on the same ssid.

I am unable to get it to connect to my home network using both the iOS app and the serial cli. Yet I can get it connect to my iPhones personal hotspot.

Since I am unable to turn off the 5ghz network, are there any other methods I could use? I would think that if it is a 2.4ghz radio it would connect to the 2.4ghz network without issue.

Is there a way to have the iOS app indicate the network frequency when scanning for networks? Maybe they could be listed separately?


#40

Hi @barskey

The usual advice for Photons is to rename the 5GHz network to have different SSID. Normally this problem has a symptom such that your device can connect just fine for a random period of time when at some point the router tries to move your device to the 5GHz network and leaves the Photon in limbo that requires a reset to recover from.

That does not sound like what you are seeing.

I also have not heard about this problem with Argons, but it is possible.