Argon can't connect through app


#61

I would try rc.26 it’s not release yet, is there a way to get it now?


#62

Well

Have to wait a little bit longer. Shouldn’t be too long anymore though.


#63

thanks @Moors7 I’ll wait…
@Particleargon I can beta test early version with my stubborn wifi network, if needed.

I just tried to connect my argon on my s9 wifi hotspot and it worked flawlessly. My home wifi still refuse to let the argon connect


#64

Hey folks! Wanted to make sure that everyone is aware that we’ve released a new version of device firmware (rc.26) that aims to address some of the first order issues affecting Android Bluetooth connectivity issues (failure to connect to device, failure to update Device OS).

After updating your devices, please restart your Particle app to ensure that the Bluetooth configuration settings are refreshed.

Instructions for updating are available here:


#65

@will Thanks for letting us know

I just upgraded to rc26.

rc25 = fast blinking green

rc26 = fast blinking green then turquoise (like it’s trying to connect to wifi) but never does :frowning:

Tried on both ios and android.

I connected the argon rc25 on my s9 hotspot in seconds. For sure there is something on my wifi network that the argon does not like. I have 9 photon connected and working flawlessly. But this argon is very stubborn.

UPDATE
I tried the same process with my other argon and boom! connected. :smile:


#66

Turquoise or, “cyan”, means that the device has successfully connected to the Wi-Fi network and is attempting to connect to the Cloud. That means that the rc.26 fix likely worked around the network issues that you were seeing.


#67

To add to Will’s statement, you are making it to wi-fi! Hooray!

So if you are fast blinking cyan on your wifi network but are able to get online just fine with your S9, I would have to guess it’s something to do with your router or network configuration.

Particle uses port 5683 for it’s CoAP protocol to communicate out. For Photon and earlier devices, this is under TCP. It is changed for Electron + all Mesh.

See if there’s anything on your router settings that may be prohibiting this as a first step.


#68

Well it’s December 29 2019 almost 2020 and this is still an issue. I cannot get this Argon working at all. Wouldn’t connect to the internet, it kept telling me some BS that my password is incorrect when it is correct. I jump through a bunch of hoops to get it connected, DNS IPV6… Finally got it connected and I went to flash some code to it using the web IDE and now it’s in a dead loop. blue and red light like it’s being flashed then dead with no lights and then back to the blue and red light. It’s caught in this loop. Where is quality control? Particle is slipping up. Putting out frustrating flawed products. Please fix this. Even the error that my password is wrong is stupid. Have an error that says what the issue is. Now I have to return 80 of these. argggggggghhhh…


#69

Could it be that your device is in safe mode, trying to update from an outdated deviceOS? Give it several minutes to see if it comes out of the red/blue (magenta).
Alternatively, place it in DFU mode, and while connected over USB issue ‘particle update’ from an up to date CLI. See if that helps?