Add Xenon to Argon Mesh

I’ve browsed the site for a bit trying all the things I could think of but I am stuck.

I’ve tried to use the CLI to update to the latest soft device on the Xenon. I’ve tried to remove all application code with a blank .bin. I’ve tried the phone app approach and it gets stuck on the adding xenon to mesh. I’ve tried to use the CLI to manually add the device.

Nothing. Thoughts?

Likely the Xenon is not correctly setup.

My advice is to download xenon-system-part1@1.4.0.bin, xenon-tinker@1.4.0.bin and xenon-bootloader@1.4.0.bin
Hold down mode button until it fast flashes blue - to clear the Mesh network details.
Put device into DFU mode flashing yellow.
particle flash --usb system part 1
particle flash --usb tinker
ensure flashing blue
particle flash --serial bootloader note --serial NOT --usb
Now try the app on a phone to setup the xenon on your mesh network (Argon).

I did your instructions. It gets to the “Adding Xenon to the mesh network” step and the Xenon starts fast blinking cyan but it fails after a minute on the app.

If I try to add it manually through the CLI, I get a Request Timeout.

Anyone else have some thoughts?

Hi @ggirard - would you mind PMing me your Xenon’s device ID? I can take a peek within our backend while others can provide further suggestions.

I’d also strongly recommend using particle update to just ensure that everything is A-OK with the OS updates.

Your Argon is breathing cyan (connected to the Cloud) correct?

I will send it over. I will try the update again when I get home.

The Argon is breathing and running fine besides that weird serial issue I mentioned in the other post.


I forgot I had the hardware with me so I was able to do it now.

Ran the update. Went through the adding process again and the same thing, not joining.
I can see both of them reset, the Argon gets to the breathing cyan state, the Xenon doesn’t get past the blinking green mode.

Another note. Using the CLI to add to the mesh network and turning on verbose. It says does register, add to the network, and claim but it says it should connect to the cloud and just keeps blinking.

For those following publicly, upon investigation within our backend this issue has been determined to be a keys issue - actionable upon following the instructions here. @ggirard, let’s continue our discussion in the support ticket in the instance that the issue requires further discussion.