Add a Xenon to a network without a supporting device

xenon
mesh
Tags: #<Tag:0x00007fe21e1bed08> #<Tag:0x00007fe21e1beb00>

#1

I don’t have easy access to any supporting devices that are already part of my network. Is there a way to add a Xenon to my network without access to supporting devices? using the CLI?

I have the command line installed and I can get the id of my Xenon (apparently it doesn’t have a name yet). Since it is not connected to a mesh network it isn’t connected to the cloud and that prevents me from adding a name.


#2

It is not possible to add a Xenon to a mesh network without access to the assisting device and the ability to put it into listening mode (blinking dark blue).


#3

@rickkas7 Ok, I tried adding my Xenon using 2 mesh network devices as assisting devices. However I get a strange error when using the app. When I use either the Argon hub or the first Xenon node as the assisting device for my second Xenon, i get an error in the app saying “the network you are trying to join is different than the network that the assisting device is connected to”. This is not correct as I only have one network available and I am using the argon hub as the assisting device. It should know it’s own network.

I also tried using the command line but that is very confusing as well. I am not sure which driver to use (libusbk or USB Serial CDC). I’ve tried both and get errors about either not finding the device or libusbk not supporting something.