Yet another solid white LED thread


I’ve been having the solid white LED problem. It worked when I first got it, but stopped after a while after trying to flash a sketch. I reflashed the firmware 0.4.7 via dfu-util, but no dice. particle setup fails after being unable to get the mac address of the device (throws a js error about not being able to get an attribute of undefined). The LED stays solid white.

If I plug the photon into the computer I can get it into Listening Mode and particle setup detects the device, but still fails after trying to access ap.mac.toLowerCase(). The Tinker app does not detect the photon.

Thanks for any help you can supply.

Can you still get your device into DFU Mode?
Have you tried particle flash --usb tinker?

Can you show the sketch you tried to flash?
Maybe we can spot the reason for the white light.

I did try that. It didn’t do anything different. I then tried to flash a blank sketch:

void setup(){}
void loop(){}

And that also did not help.

And yes, I have flashed the 0.4.7 firmware via DFU mode.

Don’t take me wrong, but how exactly did you flash the firmware?
And what was the output while doing it?

Have you got any circuitry attached?

I used the dfu-util commands found on the GitHub Latest Releases page ( The output was along the lines of “Flashed successfully”. I had a few servos attached, but I took them out when I tried flashing.

Could you try to follow these steps
Solid white light

Current version of CLI is 1.9.3.

If nothing helps you might have to go the way of the last post in there

I actually followed that post when I was troubleshooting. Looks like I’ll need an RMA.