Help with solid white LED

Got my Particle yesterday, started working through the setup procedure and got as far as connecting my Photon through my (Android) app. After that, the device never connected to the cloud, and only showed me a seemingly solid green LED. It seemed to lightly pulse, but did not appear to be ‘breathing’ like I have seen in the example videos.

After searching for a while, I came up with nothing to solve my problem so I attempted a factory reset. Now I am stuck with a solid white light. There are a few things that don’t line up with the troubleshooting instructions though:

  • The light never turns solid white before flashing white
  • Cannot enter safe mode (magenta) or firmware reset (green), but I can enter dfu (yellow flashing) mode
  • In this solid white LED mode, if I press and hold the setup button without touching the reset, it will cycle through all the modes as though I had hit the reset button first

I found a thread that seemed promising and recommended using dfu-util to flash the 0.4.2 firmware, which I tried. I then also tried 0.4.3, and 0.4.4-rc2 and after resetting the device always end up back with the solid white light.

I’m sure I’m missing something, so if anyone has any suggestions I would love to hear them.

There’s another thread talking about solid white LED. I hope this helps you solve your issue.

That was the thread I found earlier that recommended flashing the new firmware, which I did try (see end of my post) and it changed nothing for me.