Cannot setup particle photon at all; either constantly displaying solid green or white light; factory reset not working

I spent all day yesterday trying to setup my photon, and have not been successful. Here is what has happened:

  • I first tried setting it up with the iPhone app but had no success. I kept getting errors when I tried to connect it.

  • I then tried to setup using the particle CLI on my Mac, by following the instructions here: http://docs.particle.io/photon/connect/ ; this also did absolutely nothing.

  • I then tried doing a factory reset. Note this actually did do something - When I tried to connect to my iPhone App this time, my photon did register with my account. It even gave me an ID for my device. However, it was stuck in the offline state. This is currently where I am stuck; I cannot figure out how to bring it online.

  • I then tried performing a factory reset a second time. I did exactly the same thing I did the first time, but this is where all the problems came up.

  • It did not let me perform another factory reset. Instead, my photon is now stuck with either a solid white light (this happens when I try to factory reset), or a solid green light (which happens when I hit the reset button. Also, holding down the “setup” button no longer takes me to a flashing blue light anymore.

  • Please note, I can get the device into DFU mode (flashing yellow light), and I have tried updating to the most recent firmware. This, as with everything else, does absolutely nothing.

  • When I update the firmware, however, I get an error that says “dfu-util: Error during download get_status”. However, as is stated here, https://github.com/spark/firmware , this is not a big deal and should not impact anything.

  • After updating the firmware, the photon returns to a solid white light.

  • I am just trying to get the photon connected to wifi to interact with the particle cloud so that I can run programs on it.

  • I realize that there are a couple different posts around that are similar to this one, but I have tried everything in all of them and nothing works at all.

  • I really need to get this up and running asap, and would be incredibly grateful if someone could help me get this working and set up. Thank you very much for any help you can give!

@mastap94,

  • What colour was the RGB led when the core is connected but offline
  • Are you able to power up the Photon and see what colour it is at/behaving?

Let me know and i will be able to give more guidance :wink:

@kennethlimcp: Thanks so much for the offered assistance! It looks Like I somehow managed to get it working though. Having said this, I’m not very confident that it’s working well. I will keep you posted and ask another question if I encounter a similar issue again. Thanks!

1 Like

@mastap94, once a Photon gets connected and the system firmware update that is automatically happening worked well, things will be pretty stable :smile:

@mastap94, I’m experiencing this same issue, what did you end up doing to fix it? Thanks

@patcarver:

I’m 75% sure that doing this, http://support.particle.io/hc/en-us/articles/203108844-Perform-a-Full-Firmware-Upgrade-for-the-Spark-Core, is what fixed it for me. This allowed me to reset the Photon completely and just go from scratch. The 25% of uncertainty comes in because I really was just trying everything imaginable in terms of random button pressing to get it working… Hope it helps!

I’ll try it. Thanks!

1 Like

@mastap94 Got it! After following the steps you linked to above… the photon was acting differently (i thought I had it working!) but… after setup it wouldn’t connect (breathing cyan)… it would just go into breathing magenta mode… (safe?) anyway. I decided to try to install the firmware again… turns out I was installing firmware that was for the CORE, not the Photon (I’m new to GIT, and command line stuff)… Anyway after using ‘make PLATFORM=photon’ it worked like charm! Thanks for your help!

2 Likes

Glad it worked @patcarver! :smile: