Solid white light

Hi @corey ,

Trying to get my Photon working. I currently have a solid / breathing white light. I am able to get into DFU mode but when I try to update my firmware using the DFU-UTIL method it goes straight back to solid / breathing white light. I’ve also tried to flash the photon-tinker.bin file straight to my device but it again goes back to solid / breathing white light.

Any help would be appreciated.

Just to hurry the processing here are the commands i’ve used whilst in DFU mode.

dfu-util -d 2b04:d006 -a 0 -s 0x8020000 -D system-part1-0.4.4-photon.bin
dfu-util -d 2b04:d006 -a 0 -s 0x8060000:leave -D system-part2-0.4.4-photon.bin
particle flash --usb tinker-photon.bin 

particle flash --usb tinker instead of what you tried above. also make sure your device is in DFU mode.


Hi @corey,

Also tried you’re suggestion but it goes straight back to the white light. I do get the following error though

File downloaded successfully
dfu-util: Error during download get_status

Error writing firmware...dfu-util: Invalid DFU suffix signature
dfu-util: A valid DFU suffix will be required in a future dfu-util release!!!

dfu-util: Error during download get_status

I’m assuming the Error during download get_status is a bug with dfu-util?


@jjkilpatrick i have a Photon with the same behavior as yours and should be able to work with the team to determine what is wrong.

Hopefully a solution for you soon!

@kennethlimcp sounds good. I wonder if I’m going to need a Programmer Shield to get it working.

I’ve also found some more funny behaviour. After running particle flash --usb tinker and it going back to the white light, I then ran particle setup serial which does the following

> I have detected a Photon connected via USB.
? Would you like to continue with this one? Yes
! The Photon supports secure Wi-Fi setup. We'll try that first.
> No nearby Photons detected. Try the `particle help` command for more information.

So it seems like it either
a) finds it via usb and looses it or
b) it doesn’t actually try setup via usb?

Hmm… We are arrange for a RMA if there is really a need for a programmer shield that you do not have access to. Let’s wait till we hunt down this bug and hopefully give you a solution soon :wink:

1 Like

yes that dfu-util is common and is thrown back even upon a successful flash.

Also you shouldn’t have to order a programmer shield to get this working.
feel to pm me here and we can get things straightened out!


Hi All,

Any update on this?



Do you have the CLI?

If you do:

  • npm update -g particle-cli
  • place device in DFU mode
  • particle update
  • place device in DFU mode
  • particle flash --usb tinker
  • hold the SETUP button still the Photon blinks blue
  • release and hold the SETUP button until the Photon blinks blue rapidly
  • particle serial wifi
  • Let us know how it goes!


I do indeed have CLI.

I’ve followed your steps up until hold the SETUP button still on the Photon blinks blue. I’ve held it for over two minutes and it is flashing in DFU mode. However it seems that flashing tinker to the photon was successful.

dfu-util: Invalid DFU suffix signature
dfu-util: A valid DFU suffix will be required in a future dfu-util release!!!
Deducing device DFU version from functional descriptor length
Opening DFU capable USB device...
ID 2b04:d006
Run-time device DFU version 011a
Claiming USB DFU Interface...
Setting Alternate Setting #0 ...
Determining device status: state = dfuIDLE, status = 0
dfuIDLE, continuing
DFU mode device DFU version 011a
Device returned transfer size 4096
DfuSe interface name: "Internal Flash   "
Downloading to address = 0x080a0000, size = 3952
Download	[=========================] 100%         3952 bytes
Download done.
File downloaded successfully

My other buggy device now goes from DFU mode to flashing red (very sporadic, not in any order i.e two flashes or three flashes) and then turns white when I try to run particle flash --usb tinker


did you perform a particle update for both? What does particle --version say?

Also, let the Photon power up before holding on the SETUP button. It should eventually blink blue/light goes off. Release the button then hold it again till it blinks blue rapidly.

@kennethlimcp both particles are showing a version of 1.8.3

Cool. So i guess you have performed a system firmware update for both already.

Have you managed to do the steps i mentioned?

@kennethlimcp yes I’ve followed them. Everything is fine until particle flash --usb tinker which is successful. I can then not get it to blink blue. They are both cycling between blinking red light and white now.

What happens when you hold the SETUP button?

It went straight into DFU mode

It sounds to me like you have the continual reset cycle that can happen with some devices. It can be fixed if you have access to a JTAG programmer. If not, then getting a RMA is the way forward!

Sorry for this - we now know what causes this and will be rolling out an update this week that fixes it for all new unboxed Photons.


I’m getting solid white LED light after running ‘particle update’. This Photon has been working for long time. Now suddenly not working.
Put Photon in DFU and ran
particle update
particle flash --usb tinker
After doing both of these I just get White LED light on solid.
Tried Safe Mode, but when releasing SETUP while Magenta is flashing it just goes to solid White LED.
Any other ideas?

@orion411, try changing your USB cable and do the DFU update again.