Photon Failes to flash

I have a Photon, and has an early version of firmware: 0.4.1
I set up the proton. it connected to WiFi and actually used tinker for a few of the easy examples. I tried to upload an IDE file to blink the LED and it looked like it started but the LED’s all froze. I rebooted, it connected to the cloud and seemed to be working. I can read status from windows console as well as my iPhone. I can change names, but if I try to flash the cyan freezes. I tried a new USB cable. A different wifi network. I tried flashing from IDE windows. Each time I reboot, sometimes clearing wifis and stating over, tried “Signal for 10 sec” and the cyan froze. I tried flashing from command prompt “particle flash --usb tinker” (DFU mode, blinking yellow). I get this error message:

Opening DFU capable USB device…
ID 2b04:d006
Run-time device DFU version 011a
Claiming USB DFU Interface…
Setting Alternate Setting #0
Determining device status: state = dfuIDLE, status = 0
dfuIDLE, continuing
DFU mode device DFU version 011a
Device returned transfer size 4096
DfuSe interface name: "Internal Flash "
Downloading to address = 0x080a0000, size = 3952
Download [=========================] 100% 3952 bytes
Download done.
File downloaded successfully
Invalid DFU suffix signature
A valid DFU suffix will be required in a future dfu-util release!!!
Error during download get_status

Error writing firmware…Invalid DFU suffix signature
A valid DFU suffix will be required in a future dfu-util release!!!
Error during download get_status

I’m still at V 0.4.1 but nothing seems to work anymore.

I’d suggest

  1. get the most recent CLI (1.22.0)
  2. perform a system update via particle update via USB and the device in DFU Mode
  3. try anyother particle flash --usb tinker
  4. show us what code you tried to flash to the device

If you search the forum for DFU suffix you will find that this error message is just a warning which can be totally ignored.


Thanks. I do have CLI version 1.22.0. I made sure I have all the latest. I put the Proton into DFU mode (flashing yellow). then at the command prompt (in admin) and try "particle flash --usb tinker " and still get the same error message and the cyan stops breathing (solid on). Flash status on Device Inspector on iPhone reported event “spark/flash/status” failed. I have to press reset to get it back on-line. Seems like it connects to the cloud just fine, but if I try to flash via USB IDE or Web, or try “SIGNAL” to animate the LED or from my iPhone “SIGNAL FOR 10 SEC”, the breathing Cyan stops and I can no longer get status from any control panel unless I reset. The code I’m sending is “TINKER” which I think is the generic tinker script and I think it also is supposed to update firmware to 0.6.2. ? I cant get back to those simple getting started examples since I can flash tinker again.

What about 2.?

Very strange, but I tried that yesterday as well as other things, with the same results. Tried it again this morning and surprise, it worked!! Now everything now works and I’m at 0.6.2…That’s weird, but I’ll take what I can. Maybe one of the initial errors cause everything else I tried after that to fail. One benefit is that I now know about every way to communicate to it.