Photon only flashes white now

I was running a bunch of particle for a few days and noticed on of them was no longer sending data to Particle cloud. I am pretty sure the device in question was flashing fast blue. Since this condition lasted for a while I figured I would recycle the power which usually gets everything working again. After removing power, waiting, and powering up the device flashed red reset and has been flashing white ever since. The white flashing is quick and it seems D7 may be alternating with it.

I am unable to put the device in safe mode. When holding setup it will turn magenta, I release setup and it goes to flashing white again.

The device will go into DFU mode. I placed it in this mode and ran particle update, it was successful but didn’t change anything. Same issue continue.

The Photon was being powered by VIN at 5.14v though this issue happens using that supply or a USB connection from my MBP.

I have read through many of the other entires here with similar issues, but have not been able to correct this. Any suggestions are appreciated.

Make sure your CLI is up to date and issue ‘Particle update’ as well as ‘Particle flash --usb tinker’ while in DFU mode. See if that does anything?

Thank you @Moors7 for the reply.

Particle cli at version 1.23.1

Plugged Photon into usb, put Photon in DSU mode holding down setup button until flashing yellow, ran particle update
Update was successful, the Photon restarted and continued with it’s white flashing.

Put photon back into DSU mode, ran particle flash --usb tinker. It was successful. The Photon restarted and continued with it’s white flashing.

Any other suggestions?

Could you try a different USB cable/power supply?

Tried a different cable connected to a charging hub, different cable on same and another MBP, all with the same result, an immediate flashing white light.

Does the Photon feel like it’s running warmer than normal?

Is the Blue D7 led always dimly lit?

No this one is running at normal temperature. Maybe warm to the touch but not really

No, though it does alternate with the flashing white. I’ll try to get a vid if it will be helpful.

@Moors7, any other thoughts around this condition?

Thank you!

That video might be helpful, but I’ll have to defer you to @rickkas7 otherwise.

@Moors7, @rickkas7 Thanks for your continued feedback.

I checked the voltage on the photon while plugged in to MPB’s USB. VIN at 4.8 and 3.3 at about that. It changes often as seems this condition is like some booting loop.


Did you ever find a fix? I have a Photon acting the same as yours even after reflashing through DFU mode. Thanks

Hi Allan,

No, the conversation simply died. I added it to my pile of borked photons.

Kind regards,