Xenon quickstart hung up selecting mesh network

Cell phone is stuck in a loop “Select mesh network to join” in first step of quickstart xenon.
2 Zenon’s from spectra conference are installed in the featherwing. Connected to internet through switch (no router). Cell phone paired with xenon using qr code, then went into the above loop. Two xenons in same state. One xenon updated first, the other started to update but stopped and went back into the above loop also.

Checked internet connection with my pc. Works fine connecting to my pc.

Tried to do something through console, but wind up at the same place. Anyone have any clues?

Are both Xenons connected to the SAME Featherwing? I’m not sure that the Ethernet setup there should be able to cope with them both on the same board. My guess is that it was designed to have one Xenon, and the other socket to house a feather peripheral device, for example a sensor or a display. It may be worth connecting just one to the feather wing and the other powered via usb connector.

I seem to remember coming to that conclusion when I connected two simultaneously and didn’t get the behavior that I expected.

Just a guess…

1 Like

That’s definetly a no-go.

Thank you gentlemen. I figured that out too. Only one xenon on the featherwing. I returned one of the xenons back to the badge we received at the Spectra 2018 conference.
I still have the same problem. Actually, after sleeping on this problem last night, I realize I really don’t know what I am doing. At the Particle Spectra conference I paired both of my xenons, to with the iphone app where they still show up. They are also listed as devices in the particle console. It is just that both xenons just stay in the listening mode, (moderate rate blinking blue) and never start “breathing cyan” or connecting to the cloud. I don’t know how to get them to connect. What am I missing? I figured if I started over with the quickstart maybe they would re-connect to the cloud.

@TomEldredge, it may be time to “reset” your Xenons and create a new mesh network. You should have one Xenon plugged into Ethernet shield and another on a breadboard or on another FeatherWing doubler or tripler or your badge. You must have the latest Particle phone app installed on your phone.

You will need to unclaim both Xenons from your account then, on each Xenon, press the SETUP button for 10+ seconds to get the RGB led to flash blue (not cyan). This should set the stage for you to redo the setup of each Xenon through your phone app. Make sure to setup the Xenon plugged into the ethernet shield first. Also make sure to select “Use with ethernet shield” for that Xenon as it will become the gateway device. You may be asked to setup a new mesh network or the one you previously had setup may get listed so you could select that as well. Make sure to follow the app instructions carefully. If all goes well, your gateway Xenon should come online and breath cyan.

In theory, the phone app should upload a new DeviceOS to the Xenons based on rc25. After setting up the gateway, setup the other Xenon and connect it to the mesh network you had configured previously. If all goes well, your second Xenon should come online and breath cyan.

Thank you Peekay123. I was unable to unclaim one of my xenons. The other one unclaimed immediately, but the one which was once the gateway, and is connected to the featherwing and ethernet would not unclaim through the particle console.

You can also unclaim via the mobile app.

@TomEldredge, besides what @ScruffR said, try unclaiming with the Xenon/Ethernet powered and also unpowered. If nothing works, go through the process anyway to see if it comes online or not.

Thank you ScruffR, gentlemen. I was able to unclaim the xenon using the app. Now I will follow Peekay123’s proceedures and try to start over.

Started over. Paired first xenon with cell phone successfully, then the app displays "Select mesh network to join, with a little rotating icon beneath it, but it does nothing else-just sits there.
It does not list any network to join.
Thanks again for your support.
Tom

I have the xenon plugged into the featherwing, and I have a good ethernet connection to it. (The ethernet works fine with my pc) The ethernet cable is connected to a netgear n300 Wifi Router.

@TomEldredge, had you selected “use with ethernet shield” when you first started setting up that Xenon?

1 Like

Problem solved. Particle had sent a text to my cell phone to install the app. I thought it installed it when I selected the link in the message, but it did not. Maybe I should have uninstalled the old app first. Anyway the problem was caused by not having the most current iphone app.

Problem solved.

1 Like