All Xenons suddenly stopped working


#1

I have a small mesh network with one Boron (third party SIM) and two Xenons. It’s been working fine for weeks, but sometime in the last few days both Xenons suddenly stopped working.

The Boron is working fine. It’s breathing Cyan and I can ping it, flash it, and invoke function calls.

Both Xenons were behaving the same way: When powered up, they slow-flash green for a while, then quick-flash green, but never get any farther than that. I’ve left one of them un-touched, but as an experiment I tried unclaiming the other one and attempting re-join the mesh network. I used the particle app to scan the code on the Xenon (which pairs). Then I scan the sticker on the Boron and get “Congrats! Successfully paired with Boron-XXXXX.” But it hangs there and never finishes the process, so I’m unable to get it back on my mesh.

Bottom line is that I’m dead in the water. One Xenon can’t be added to my account, and the other (while still showing up on my account) is useless because it’s stuck flashing green.

Has anyone seen anything like this? Any suggestions for next steps?


#2

I had similar issues. I unclaimed my XENON and did a network reset. However, when I went to add it back to my mesh, it still asked me if I wanted to leave the network or cancel setup. Strange since I thought this is what a network reset should accomplish. So, I then did a factory reset. Once I had completed those steps I flashed TINKER to my devices and was finally able to re-establish my mesh. I also found that if I was running my firmware on the BORON, which uses ApplicationWatchdog wd(60000, resetDevice); was causing the XENON setup to hang. By either increasing the value of the timer or flashing TINKER, I was then able to add XENON’s to my mesh. Hope that helps you
https://docs.particle.io/tutorials/device-os/led/xenon/#network-reset-fast-blinking-blue-
https://docs.particle.io/tutorials/device-os/led/xenon/#factory-reset


#3

When you are resetting the device or unclaim your device you are not resetting the information about network association in the cloud, that’s why the app asks you if you want that to happen too.


#4

Noted, thanks for the explanation and it makes sense now. I did not see that in the documents anywhere, must have missed it?


#5

Thanks for the suggestions. Unfortunately, I don’t think it explains my situation. My Boron code is not uinsg ApplicationWatchdog() (or anything else that would cause it to reset), and the web GUI shows that the removed Xenon has been removed from the mesh network in the cloud.

I also tried doing a factory reset on the Xenon and it didn’t change anything. I’m able to claim the device to my account, but I can’t get onto the mesh network. All of my Xenons are still bricks.


#6

Well, I got it working. It’s puzzling (and frustrating) to have to do this, but after many (many!) attempts to recover my mesh network (using various combinations of resets, factory restores, unclaiming, claiming, etc.), all without success, I finally ended up un-claiming all three devices, and starting over from scratch with a NEW mesh network. For whatever reason, that worked perfectly: The Boron was claimed with the new mesh network name, and both Xenons were added to the new network using the Android app on the first attempt.

I still have no idea why I needed to do that, and I hope I don’t have to do it too often. It’s acting as if my mesh network was disabled in the cloud and every attempt to do anything with that network was rejected. Once I switched to new network everything was great!