Xenon on Ethernet, Setup Error- searching for mesh network


#1

trying to use xenon as standalone device on ethernet shield.

  1. xenon in setup mode (blue slow flash)
  2. plugged into particle ethernet featherwing. (adafruit product 4003, claims to include the pin mods needed for particle.)
  3. ethernet port lights flashing, showing traffic or connection to router.
  4. fire up mobile app do softAPsetup. select “toggle ethernet featherwing setup”, pairs, does firmware update.
  5. goes to mesh network search and displays “Select mesh network to join”.
  6. never completes and forces setup exit.

#2

I have setup 4-5 Xenons in Particle Ethernet featherwing with zero issues.

Curious what step 5 is - device should be a gateway in which case you would be creating a Mesh network not scanning and joining an existing one.


#4

Good to hear it can work with this hardware combo.

on the android app (updated and reinstalled yesterday), here is the sequence of screens I see.




#5

I also get the same behavior as above when:

  1. Argon is disconnected from the ethernet wing
  2. “toggle Ethernet Featherwing setup” is set to True

as if the ethernet wing is not recognized by the device maybe?

also I am experiencing different LED behavior when the argon is plugged into the ethernet shield.
please see attached video of LEDs.
https://www.dropbox.com/s/uhfdlzfvasjy76i/Particle%20LED.mp4?dl=0


#6

Hi, Particle Android dev here,

Yeah, may be that the featherwing isn’t being detected or may be defective somehow. Regardless, I’ll verify this flow sometime today and let you know what I find.

In the meantime, what firmware are you running on the Xenon? Have you tried upgrading to 1.4.2? (For reliability reasons, instead of upgrading to the very latest Device OS release, the mobile app only upgrades devices to as recent a release as is necessary to complete setup/use Control Panel.)


#7

version%2C%20id%20scrub
yes, updated via cli.
I am thinking hardware issue as I also have a argon which shows the same blink pattern only when connected to the ethernet shield. Did you see those in the dropbox link?
I also tried with older firmware 1.1 and had the same issues.


#8

In the video there is no Ethernet connection available, hence it’s not surprising that no mesh can be registered - when using the Xenon in an EtherWing it becomes a mesh gateway any wants to create a network - not join an existing one.


#9

confirmed hardware/wiring issue, on my end. An analog pin tied to ground was apparently causing the issue. The light issue does not happen when the pin is grounded during startup with the argon alone, only when it is plugged into the ethernet shield.
So its working now with the xenon and the in app setup went through just fine.
thanks for the responses.