Particle Ethernet Featherwing Unable to Communicate Through Ethernet


We bought three Particle Ethernet Feather-wings alongside with three POE Modules to use with both Xenon boards as well as third party boards (Adafruit Feather M4 Express). We seem to have what it looks like as two defective boards, but we don’t want to come to any conclusions without extensive testing.

Background Information:
For the third party units, we are using Ethernet2 library, which we have tested on several boards using the W5500 chip. According to the schematics and documentation, this feather-wing should be ported over without any problems and through testing we are assuming it is. Once this works, we will be using the Xenon boards for more specific communications.

We got code up and running on all three boards, we plugged them into our POE switch and 1 of the 3 connected and ran fine. The other two seem to never connect to the switch (green Ethernet jack not on). The only different between the three code is the IP and MAC that we are using to create our server/client. Next, we plugged the POE module into the working board to ensure that all three POE modules are working, which they did. Next, we took the two Adafruit boards that didn’t connect and plugged them into the single working feather-wing board. They started working as expected. We went back to the two other feather-wings and they stopped working again.

We are wondering what could cause 2 of the 3 boards to not work correctly and if we should assume that these two feather-wings boards could be shot.

Our current setup without ethernet plugged in:


@Jeffery I have about 4 Xenons in Particle Ethernet Feather wings - all work fine. On setup you need to enable the Xenon Device OS to use the Ethernet connection. I don’t think the Featherwing has been designed to work with other boards like the Feather M4 Express as shown in you picture.

The issue for a lot of users is that the board uses pins D4 and D5 which renders use of SPI1 impossible and SPI is solely for the ethernet adaptor. Thus, any other peripherals must use I2C.

Thank you for your response.

We do realize that the Particle Ethernet Featherwing is designed to work for the Particle boards and not the Adafruit. We took into account the D3, D4, D5 (reset, interrupt, and CS pins) and modified the Adafruit board to work with those pins. We also took into account that SPI1 will not be able to be used with other peripherals which is fine.

The problem comes down to why only one featherwing works, while the others doesn’t.

Our next step was to take our Xenon and go through the setup process on the Particle App, while enabling the Ethernet connection. As result, the Xenon couldn’t communicate with our switch from the boards that also didn’t work with the Adafruit. We tried putting the Xenon board into the single working Particle Ethernet Featherwing and it connected to the switch just fine and successfully went through the setup process.

Next, we got our hands on two additional boards from Particle and got the same results. They didn’t work with either the Xenon nor the Adafruit boards.

Additional Information:
Using the Adafruit board, we programmed some code to talk to the W5500. It seems with using all the boards we are able to communicate with the W5500 just fine, but the W5500 is not receiving any communications from the Ethernet port that we have plugged into our switch (we tried multiple ports).

Is their any other suggestions?

@Jeffery Maybe as you suggest you have been unlucky and got 2 duff Ethernet Featherwings. I presume you have tried both without the PoE adaptor board? I have never used that board but rather just bought an adaptor lead. Suggest to log a support ticket - Particle have always been very good about replacing faulty hardware with me.

Thanks for the reply,

That is our opinion as well. We tried connecting the Ethernet Featherwing straight to the switch with no board attached, supplied the W5500 with 3V and only the one W5500 started communicating to the switch. This made us eliminate both the Adafruit/Xenon board as well as the POE module from the equation and only the Featherwing remains. Still unsure why they wouldn’t work, but I will log a support ticket with Particle.

We are still open to try any possible ideas to see why the Ethernet Featherwings are not working while we log this issue.