XENON mesh-Bluetooth dropped

I have 3 brand new XENONS that get almost through the process and when I reach “Adding Xenon to the mesh network” I get an ERROR telling me the bluetooth has been dropped unexpectedly. I tired several times on all 3 and never get past this point.

So, I took another, brand new, never been used XENON out of the box. On the first attempt, I got past the ADDING step to the final step and THEN I got the ERROR that the bluetooth dropped. I tried it again and this time it connected to the cloud (breathing cyan) but before I got a chance to name it, the dreaded ERROR message once again. So, my device ended up being called no name.

Any suggestions on the 3 that do not get past the ERROR message would be appreciated.

there was another thread like this recently. i think it was solved by first updating the xenon with the cli then doing the setup with app,

@ dkryder Thanks for your reply. My issue is not related to being able to update to 0.9.0. As a matter of fact if they are not 0.9.0 when you attempt to set them up, the first thing that happens is they update to the latest version, in this case 0.9.0.

It also does not explain the flaky behavior of the one I did manage to add, which dropped the bluetooth at the very last second. Although the Xenon ended up breathing cyan, I never was given the option to name it and it ended up being listed as “no name” in the app.

So, the xenons all are running 0.9.0 and I have the latest app along with 3 xenons that I cannot get to join the network. I have 2 that I was able to join to the network and 4 more that I have not tried yet.

well, it seems this “bluetooth connection was dropped unexpectedly” issue has a new variant. i’m sure either you or someone else will find the solution.

That is an easy fix. The device should show up in Web IDE where you can name it - the device name is not stored on the device but in the cloud.

Just a stab in the dark but can you try with another mobile device?

@ScruffR Thanks for your reply. Yes, I was able to name the device and of course that is not the real issue. I could try an android device instead of my iPhone. Ill do that and report back.
Thank you

1 Like

@ScruffR So I was able to get my hands on an Android device this morning. I went through the pairing process and it failed at the same point-“adding Argon to network” . Strange thing is, there is no error message saying the bluetooh connection was lost, I just had a spinning wheel and never got past that point.

The app was downloaded prior to trying so it should be the latest version. The phone was a samsung galaxy S9 with the latest update having been done on the phone 3/16/2019

Thank you

Can you try again and then list step-by-step what exactly you do at each step.
I suspect the error happens after the app has asked for an assisting device (is the Argon and the Xenon blinking blue and have you scanned the Argon’s data matrix?)

BTW, you currently cannot add an Argon to an existing mesh network.

Sorry, that was a typo. I am trying to add XENON not ARGON.

-open app
-click + sign
-select Argon/Boron/Xenon in the Setup a new device tab
-scan data matrix
-plug in power source, confirm blinking blue, click next
-successfully pairs
-ok lets get this mesh node connected…click next
-select mesh node to join
-add xenon to mesh network
-assisting device blinking blue, click
-scan assisting device, click
-successfully paired with Boron
-enter network password
-click join network
-requesting permission
-adding xenon to network

  • THIS TIME it made it all the way to Starting secure session, then I got the ERROR screen as pasted above
    -xenon is blinking cyan, then 3 blinks of yellow/red followed by blinking cyan

It never connects and does not show up in my device list in either the IDE or the app. Tried pressing reset, same result of blinking cyan, yellow/red 3 blinks, blinking cyan. Disconnected power, reapplied power same sequence with led.

Thank you