Bluetooth connection (immediately) unexpectedly dropped during setup

xenon
Tags: #<Tag:0x00007f1c9e608300>

#1

I have been away from working with the mesh products for over a month, but I don’t recall having this problem before. Xenon setup: Using mobile app, after successfully pairing with the Xenon, and as the update screen started, the iphone app immediately reported, Error, the bluetooth connection was dropped unexpectedly…

I have tried this with two different xenons, same thing. I see no reason why the iphone bluetooth would produce this. Isn’t the update trying to go through the iphone?


#2

What version of the iOS app are you running? (It’s on the login screen.)


#3

using v2.8.1


#4

2.8.2 is in the App Store – can you try that version?


#5

I tried it this afternoon with 2.8.2. Same symptom. Pairs successfully then as soon as the update begins, I get the same error.I can see the xenon go from blinking blue to purple (red and blue together) then it flashes red, and eventually goes back to flashing blue (listening mode).


#6

I’m assuming these Xenons are brand-new, and are still running the factory firmware. I’m not sure why you’re having that difficulty…

Here’s what I would try first:

  1. Network reset the Xenon
  2. Force-quit the Particle app
  3. Turn Bluetooth off, then on again on your phone (I have no idea if this has any effect, but it can’t hurt)
  4. Try to set up again

If that doesn’t work, I suggest downloading the CLI tool, and then go grab the Device OS files, bootloader, and Tinker .bin files listed below from here and then do this:

  1. Connect the Xenon via USB.
  2. put it into DFU mode
  3. Atr a command prompt, cd to the directory containing the .bin files and enter particle flash --usb system-part1-0.8.0-rc.27-xenon.bin
  4. particle flash --usb tinker-0.8.0-rc.27-xenon.bin
  5. put it into Listening mode
  6. particle flash --serial bootloader-0.8.0-rc.27-xenon.bin

I hope one of those two things helps!


#7

@TomEldredge Hey, I just wanted to check and see if the solution that @ParticleD gave solved that for you!

Let me know!

Thanks,
Kevin


#8

Gentlemen,

The xenons I am using were purchased in November 2018. They were set up with out problems and used for testing/training purposes at the time with no issues. I just set them aside and worked on other projects for a while.

Here is what I have tried in the last couple of days:

  1. Downloaded the iphone app on another good cell phone and tried again. Same symptom: bluetooth connection was dropped unexpectedly while beginning the update.

  2. Went to a different location with faster internet. This is at a nearby factory and I tried it right in their programmers’ offices. Same symptom.
    Concluding that this is a problem with my xenons, or firmware.

I used the dfu mode to update the firmware in my xenon using the below command in the command window:
C:>particle flash --usb C:\Users\Tom\Downloads\hybrid-0.8.0-rc.27-xenon.bin

It flashed successfully it said, however, I am used to seeing the xenon show a red/blue led while it is updating. I only observed a different rate of blinking the yellow led while it updated.

I went back to the particle app (ver v2.8.2) and began the setup again. This time, the xenon did not try to update, because I had just updated the firmware. The process went well, paired with the app, and I had the assisting device (Argon with new firmware loaded in it) blinking blue. Then the app paired successfully with the Argon. I selected the network and entered the password. As it tried to join the network and the iphone app displayed “adding xenon to the mesh network” the app suddenly reported “Error The Bluetooth connection was dropped unexpectedly…”

I tried it four times with the same results.


#9

When you update via DFU that is normal - the magenta phase only happens for OTA or Y-Modem (--serial) update.


#10

I see that I did not update the system , tinker, and bootloader as recommended. I will try all of them now. I’m sorry for not reading the suggestion from Particle carefully enough.


#11

Gentlemen,
Being an old guy, I gave up on trying to make my windows 7 drivers work and now I’m limping along with my IMAC which I bought to work on these mesh devices. Can someone please tell me the exact command line I would need to enter in the iTerm to flash the firmware to my xenons using the IMAC? The 0.9.0 files are in the downloads folder in the dock. I tried this, but it did not work:
"particle flash --serial downloads\bootloader-0.9.0-xenon.bin"
I also tried to upgrade the cli following the instruction:
"npm install -g particle-cli"
Obviously, I am not familiar with the file structure of the IMAC yet.


#12

The docs recommend installing CLI on Mac/Linux with

bash <( curl -sL https://particle.io/install-cli )

So if you enter particle --version and a version number does not come up (the latest is 1.39.0), then do the bash thing. Afterward, see if the version # comes up correctly; if you do that, then you should be able to flash the 0.9.0 system-part1, Tinker, and bootloader to your device.

BTW flash system-part1 and Tinker via --usb (DFU) mode first, and then do the bootloader in --serial mode.

With device in DFU mode mode:
particle flash --usb system-part1-0.9.0-xenon.bin
particle flash --usb tinker-0.9.0-xenon.bin

With device in Listening mode:
particle flash --serial bootloader-0.9.0-xenon.bin


Argon seems to be stuck flashing yellow
#13

Thank you gentlemen for all your help. It appears that updating the firmware to 0.9.0 on at 2 of my xenons has ended my bluetooth disconnection issues.


XENON mesh-Bluetooth dropped