Pairing / Setup of Xenon


#1

I’m trying to setup my Xenon from Spectra (badge Xenon). I unclaimed it, and I’m trying to set it up on the iOS app. After scanning it successfully pairs, but then just sits on that screen and nothing else happens. What is supposed to happen next?

I’ve tried a few times, killed the app, re-run same result. I have the latest version of the iOS app on an iPhone X.

UPDATE: NEVERMIND. The shaming of my Xenon’s performance on the Particle forum was enough to shake it’s conscience into working again. About the 10th attempt, it went to the next screen… go figure.

UPDATE 2: Well I can get past that successfully paired screen about 1/2 the time, but when Updating Device OS, we get no where. Sits at 0% done indefinitely (ok I’m impatient and haven’t given it more than 3 minutes at a time, but it should do SOMETHING within 3 minutes am I right?).

So, back to square 1, or 1.2 anyway. Stuck updating Device OS from iOS app. Any one experience and overcome similar? I guess I’ll just let the app run for a while and see if something magically happens again after 5, 10, 30 minutes…


Xenons not making Cloud Connection via mesh
#2

For Spectra Xenons, you should be able to do the major device OS upgrade by USB, which may help get past some of the bluetooth issues you are having.

particle flash --usb hybrid-0.8.0-rc.25-xenon.bin

Then go back to the mobile setup and it should go more quickly as the Xenon already has up-to-date firmware.


#3

Thanks Rick, will check as soon as I get home. Didn’t cross my mind to just serial flash with latest and greatest…


#4

Well, I can’t get any computer to recognize this Xenon in DFU mode from the CLI. Mac and Windows PC - both can flash photon and electron no problemo. I tried to put in BLUE mode and do a flash also not getting any response.

The Xenon is definitely in DFU mode. Is it possible it’s bricked?


#5

When the drivers won’t install automatically with the CLI installer in Windows you need to have the device in DFU Mode and then install the drivers via zadig.
I’ve best results with libusbK drivers.


#6

I don’t think it’s the drivers, I can flash other Particle devices on my Windows PC and my Macbook. I can successfully particle identify the Xenon too… so, that makes it even fuzzier to me what might be going on.


#7

You need to inform Windows that it should use the already installed drivers with the newly added Xenon. The fact that Windos knows one device and which driver to use for it is no proof that it would be able to guess the same for a completely novel device Windows never had seen before.

Does the Xenon show up as libusbK device in DevMgr? If not, I still think it has to do with the drivers (at least for Windows).

That’s nothing to do with DFU - that’s USB Serial (= different drivers)


#8

It did not show up that way. Zadig’d it up and now I was able to flash, thanks for your help!

Upon resetting, pulling power and re-powering, now getting a status led color I’ve not seen yet…

I see it’s not animating on the forum, but it’s flashing this color - very light blue, not quite white, not quite cyan. I can reflash over and over in DFU, and it flashes successful.


#9

Sorry for the late reply. But this might actually be white (with a hint of blue due to color imbalance).
If it’s breathing that way, you may be running SEMI_AUTOMATIC or MANUAL mode and hence not power up the radio(s).