Xenon blinking green after breathing cyan


I really would like to try the RC26 to see if it gets better … but where do you fin dit? For my account it’s neither in “build”:

nor on GitHub

neither worked by reinstalling the Argon from the iOS app (still RC25)… Am I missing something?


0.8.0-rc.26 is currently being tested and not available yet.

We spent several hours fighting with both Argons and Xenons with rc.26 showing up and disappearing. We also kept having the issue of losing the serial port so while you could flash new code, you couldn’t get any output via the serial port. If you put the units into listen mode, you could hear the serial port initialize and it appeared to be ok. As soon as you gave it wireless credentials, it would connect to the wireless network and then disable the serial port. If I hadn’t waited 9 months to get these new devices, I probably would have thrown them out the back door.

1 Like

We also kept having the issue of losing the serial port so while you could flash new code, you couldn’t get any output via the serial port.

Are you using Serial.begin(9600) in your setup()?

Is your user code doing some form of Serial.print() and you are seeing that it does not show up in the serial terminal?

I saw this same thing after I tried to update to rc-26 (when it was present in the IDE and flashing Tinker to the device). I just tested again, and unlike on my Photon (on 0.7.0) which finds the serial port whether or not I have Serial.begin(), the Argon, on rc-25, only finds the serial port if there is a Serial.begin(). Has the use of that been made explicit? Given this behavior, it makes sense that we didn’t see the serial port after the attempted upgrade to rc-26, since it put Tinker on the device, and it doesn’t have a Serial.begin() in the code.

@kennethlimcp, yes, I am doing both the begin and the print.

The problem is that at the OS level the serial ports are not being initialized. When you go into the Device manager in Windows it says there are no serial ports available. If you go into CoolTerm it says there are no devices available. If you go into PuTTY it says there are no devices available. This problem didn’t start until the phantom .26 code started showing up sometime after lunch.

In fact, I had hooked up a uBlox M6 to my Argon and it was spitting out GPS data with no problem, and I was serial monitoring it with no problem. After lunch I wanted to move the uBlox to the Xenon and mesh it over to the Argon, which would then upload it to the Internet. That’s when I started seeing the .26 code become an option and things started breaking. Same exact code that worked before lunch broke horribly since the serial ports would not initialize. This happened with Argons, Xenons, and multiple laptops.

Have you reverted to rc-25?, because if you haven’t, your code with the Serial.begin() is no longer on your device, Tinker is (or at least that’s what happened to me when I tried to upgrade to rc-26). This re-flashing of Tinker is discussed in this thread.

@ric, yes I did, no change.

I was able to get the Argon back on-line by re-flashing the GPS code at .25. I tried doing the same with the Xenon but it still does the same thing: blinking blue with no wifi creds and the serial port active. Once I put in valid wifi creds it breathes properly but does not init the serial port, even with non-Tinker code.

After spending the whole afternoon I just threw everything back into the box. I haven’t had the time or patience to start on round 2. Just reporting my findings.

1 Like

Looks like some could test RC26, so what are the criterias. I would like to test it, because i have nothing to loose, my all Argons and Xenons are unusable in this state.

Best regards,


@steven_r, I believe RC.26 hasn’t cleared Particle’s internal testing yet. According to a post by @ParticleD, they just started that testing late last week or this weekend.

@ninjatill, ok then i can wait a little, but if Particle is looking for early testers… i am ready to :wink:


1 Like

I didn’t read this whole thread, but re: serial port – there was an intentional change for at least the mesh products (I’m no sure if this will make its way into the 2nd gen devices) where if you don’t have a Serial.* function call in your code, the serial port will not be initialized. I am curious to know why that decision was made but haven’t found out yet. If I do I will post here.

1 Like

IIRC that was to allow for the more flexible USB control requests scheme which would be more “complicated” to achieve with an already “preoccupied” USB CDC interface.
But the engineers will know more to tell :blush:

I have the same issue. My Xenons connect to the mesh. They’re all breathing Cyan and I can Control them via tinker. After some minutes they’re flashing green and aren’t reachable anymore. I have to wait now until this issue is solved.

While you wait for the new version, if you want to have some fun, setup a new wifi network with your phone or with a pc that has wifi and ethernet (search setup mobile hotspot on windows). That should work for now :slight_smile:

Hello dear Particle guys,

Any news on the new firmware that would make our Argon+Xenon finally usable for those who cannot turn off IPV6 support in their router?


1 Like

@steven_r, soon, very soon :wink:

Hey folks – rc.26 is now available to be flashed to 3rd gen devices. Instructions for doing so is available here:

Please let us know if this helps to resolve the Xenon reconnect issues that you’ve been experiencing.

1 Like

I think this issue is related to stored credentials that remain in xenon or argon. I’m having the same problem now after I factory-reset the Argon to get debugging working. this I got working but I cannot get my mesh backup.

I can flash the xenon and reconnect to serial. After factory reset of the xenon and setting it to an new mesh network of the argon it now I was able to reconnect.

So I conclude that the router has nothing to do with it. It is a state in both xenon and argon that gets you in the blinking green. After I reseted the Argon the problem of green went away but there was blinking blue. So now I resetted the xenon and manually torn on mehs and resubscribe to my functions. This finally made the devices, both xenon and argon back accessible.

To particle please review your reset and clean functions. Both in setting up debug and in configuring mesh I get the feeling that not everything gets cleared out. Especially the secure things like wifi and mesh credentials. Anyway I’m back online sorry for the lengthy post I hope this saves someone else some time.

Also I noticed Mesh and ibeacon do not mix well. Reading https://docs.particle.io/workshops/particle-101-workshop/ble/ for using both now …