Xenon blinking 3x orange while trying to connect to cloud


#1

I had my little mesh network up and running (two xenons from spectra, one in ethernet wing). I upgraded them to 0.8.0.rc25 and everything was working nicely. But… my stand-alone Xenon all of a sudden got stuck connecting to the cloud (fast cyan blinking) and periodically showed 3 orange blinks.
3xOrange_small
This mode is not described on the Xenon Led Signalling page. However, it mentions that orange blinking is linked to bad server keys. So I tried the repair suggested. It didn’t work, see screenshot:

What has happened?


#2

I have found a solution, albeit not a pretty one… I put the device in DFU mode, and flashed tinker to it. Still no luck. Then I unclaimed the device from my phone, put the device in listening mode, and set it up once more, and put it back on the mesh network. So far a crude solution, but what happened, and how to avoid it?


#3

What type of device are you using as your gateway?


#4

The other xenon, in an Ethernet featherwing.


#5

I had the same problem, It was caused by another xenon calling a function over mesh in the failed xenon repeatedly without enough time to complete the function