Windows CLI Installer fails

It tells Setup was completed successfully.

But in the textbox there is:

particle: Installing plugins…
!
! exit status 3221225477

And the same error occurs again when calling “particle setup” from command prompt.

Uninstall and re-install did not help.

On a different notebook it worked, now I have a second account. But on wrong notebook for work.

Copy pasting the error or a screenshot would be helpful.

image

Had to add a keyboard with Print Screen button first! Thanks.

Could your firewall/proxy be blocking the download of suplemental packages?
The installer will acquire additional packages on demand, if that’s blocked that may cause such issues.

No, I don’t thinks so. I use this desktop on my IoT WLAN on a separate internet connection, but also tried with a cloned Windows 10 (WinToUSB) with the same desktop on my normal WLAN/WAN connection as with the other notebook where it worked; this failed also. I will later look at Windows event viewer if I find out more. I can use the other notebook with Windows CLI.

1 Like

I think I found out why I can’t install Particle CLI on my MINIX N42C-4 mini desktop PC:

My MINIX N42C-4 has no USB 2.0 connections, only USB 3.0.

Microsoft Windows [Version 10.0.17134.471]
(c) 2018 Microsoft Corporation. All rights reserved.

C:\Users\ZinggJ>node -v
v10.14.2

C:\Users\ZinggJ>npm -v
6.4.1

C:\Users\ZinggJ>npm install -g particle-cli
npm WARN deprecated node-uuid@1.4.8: Use uuid module instead
npm WARN deprecated cryptiles@2.0.5: This version is no longer maintained. Please upgrade to the latest version.
npm WARN deprecated boom@2.10.1: This version is no longer maintained. Please upgrade to the latest version.
npm WARN deprecated hoek@2.16.3: This version is no longer maintained. Please upgrade to the latest version.
npm WARN deprecated parser-delimiter@1.0.2: reanmed to @serialport/parser-delimiter
npm WARN deprecated parser-cctalk@1.0.2: reanmed to @serialport/parser-cctalk
npm WARN deprecated parser-readline@1.0.2: reanmed to @serialport/parser-readline
npm WARN deprecated parser-byte-length@1.0.2: renamed to @serialport/parser-byte-length
npm WARN deprecated parser-ready@1.0.2: reanmed to @serialport/parser-ready
npm WARN deprecated parser-regex@1.0.2: reanmed to @serialport/parser-regex
C:\Users\ZinggJ\AppData\Roaming\npm\particle -> C:\Users\ZinggJ\AppData\Roaming\npm\node_modules\particle-cli\bin\particle.js

> serialport@6.2.0 install C:\Users\ZinggJ\AppData\Roaming\npm\node_modules\particle-cli\node_modules\serialport
> prebuild-install || node-gyp rebuild

prebuild-install WARN install No prebuilt binaries found (target=10.14.2 runtime=node arch=x64 platform=win32)

C:\Users\ZinggJ\AppData\Roaming\npm\node_modules\particle-cli\node_modules\serialport>if not defined npm_config_node_gyp (node "C:\Program Files\nodejs\node_modules\npm\node_modules\npm-lifecycle\node-gyp-bin\\..\..\node_modules\node-gyp\bin\node-gyp.js" rebuild )  else (node "C:\Program Files\nodejs\node_modules\npm\node_modules\node-gyp\bin\node-gyp.js" rebuild )
gyp ERR! configure error
gyp ERR! stack Error: Can't find Python executable "python", you can set the PYTHON env variable.
gyp ERR! stack     at PythonFinder.failNoPython (C:\Program Files\nodejs\node_modules\npm\node_modules\node-gyp\lib\configure.js:484:19)
gyp ERR! stack     at PythonFinder.<anonymous> (C:\Program Files\nodejs\node_modules\npm\node_modules\node-gyp\lib\configure.js:509:16)
gyp ERR! stack     at C:\Program Files\nodejs\node_modules\npm\node_modules\graceful-fs\polyfills.js:284:29
gyp ERR! stack     at FSReqWrap.oncomplete (fs.js:154:21)
gyp ERR! System Windows_NT 10.0.17134
gyp ERR! command "C:\\Program Files\\nodejs\\node.exe" "C:\\Program Files\\nodejs\\node_modules\\npm\\node_modules\\node-gyp\\bin\\node-gyp.js" "rebuild"
gyp ERR! cwd C:\Users\ZinggJ\AppData\Roaming\npm\node_modules\particle-cli\node_modules\serialport
gyp ERR! node -v v10.14.2
gyp ERR! node-gyp -v v3.8.0
gyp ERR! not ok
npm ERR! code ELIFECYCLE
npm ERR! errno 1
npm ERR! serialport@6.2.0 install: `prebuild-install || node-gyp rebuild`
npm ERR! Exit status 1
npm ERR!
npm ERR! Failed at the serialport@6.2.0 install script.
npm ERR! This is probably not a problem with npm. There is likely additional logging output above.

npm ERR! A complete log of this run can be found in:
npm ERR!     C:\Users\ZinggJ\AppData\Roaming\npm-cache\_logs\2018-12-18T07_32_28_881Z-debug.log

C:\Users\ZinggJ>

15057 info lifecycle node-wifiscanner2@1.2.0~install: node-wifiscanner2@1.2.0
15058 silly install particle-commands@0.3.0
15059 info lifecycle particle-commands@0.3.0~install: particle-commands@0.3.0
15060 silly install request@2.75.1-relativepath.1
15061 info lifecycle request@2.75.1-relativepath.1~install: request@2.75.1-relativepath.1
15062 silly install serialport@6.2.0
15063 info lifecycle serialport@6.2.0~install: serialport@6.2.0
15064 verbose lifecycle serialport@6.2.0~install: unsafe-perm in lifecycle true
15065 verbose lifecycle serialport@6.2.0~install: PATH: C:\Program Files\nodejs\node_modules\npm\node_modules\npm-lifecycle\node-gyp-bin;C:\Users\ZinggJ\AppData\Roaming\npm\node_modules\particle-cli\node_modules\serialport\node_modules\.bin;C:\Users\ZinggJ\AppData\Roaming\npm\node_modules\particle-cli\node_modules\.bin;C:\Users\ZinggJ\AppData\Roaming\npm\node_modules\.bin;C:\Program Files (x86)\Intel\iCLS Client\;C:\Program Files\Intel\iCLS Client\;C:\WINDOWS\system32;C:\WINDOWS;C:\WINDOWS\System32\Wbem;C:\WINDOWS\System32\WindowsPowerShell\v1.0\;C:\Program Files\Intel\TXE Components\DAL\;C:\Program Files (x86)\Intel\TXE Components\DAL\;C:\Program Files\Intel\TXE Components\IPT\;C:\Program Files (x86)\Intel\TXE Components\IPT\;C:\Program Files\Intel\WiFi\bin\;C:\Program Files\Common Files\Intel\WirelessCommon\;C:\WINDOWS\System32\OpenSSH\;C:\Program Files (x86)\Common Files\Acronis\VirtualFile\;C:\Program Files (x86)\Common Files\Acronis\VirtualFile64\;C:\Program Files (x86)\Common Files\Acronis\FileProtector\;C:\Program Files (x86)\Common Files\Acronis\FileProtector64\;C:\Program Files (x86)\Common Files\Acronis\SnapAPI\;C:\Program Files\nodejs\;C:\Users\ZinggJ\AppData\Local\Microsoft\WindowsApps;C:\Users\ZinggJ\AppData\Local\particledev\bin;C:\Users\ZinggJ\AppData\Local\particle\bin;C:\OpenSSL-Win32\bin;C:\Users\ZinggJ\AppData\Roaming\npm
15066 verbose lifecycle serialport@6.2.0~install: CWD: C:\Users\ZinggJ\AppData\Roaming\npm\node_modules\particle-cli\node_modules\serialport
15067 silly lifecycle serialport@6.2.0~install: Args: [ '/d /s /c', 'prebuild-install || node-gyp rebuild' ]
15068 silly lifecycle serialport@6.2.0~install: Returned: code: 1  signal: null
15069 info lifecycle serialport@6.2.0~install: Failed to exec install script
15070 timing action:install Completed in 2052ms
15071 verbose unlock done using C:\Users\ZinggJ\AppData\Roaming\npm-cache\_locks\staging-e3dae329e7532615.lock for C:\Users\ZinggJ\AppData\Roaming\npm\node_modules\.staging
15072 timing stage:rollbackFailedOptional Completed in 7838ms
15073 timing stage:runTopLevelLifecycles Completed in 79143ms
15074 verbose stack Error: serialport@6.2.0 install: `prebuild-install || node-gyp rebuild`
15074 verbose stack Exit status 1
15074 verbose stack     at EventEmitter.<anonymous> (C:\Program Files\nodejs\node_modules\npm\node_modules\npm-lifecycle\index.js:301:16)
15074 verbose stack     at EventEmitter.emit (events.js:182:13)
15074 verbose stack     at ChildProcess.<anonymous> (C:\Program Files\nodejs\node_modules\npm\node_modules\npm-lifecycle\lib\spawn.js:55:14)
15074 verbose stack     at ChildProcess.emit (events.js:182:13)
15074 verbose stack     at maybeClose (internal/child_process.js:962:16)
15074 verbose stack     at Process.ChildProcess._handle.onexit (internal/child_process.js:251:5)
15075 verbose pkgid serialport@6.2.0
15076 verbose cwd C:\Users\ZinggJ
15077 verbose Windows_NT 10.0.17134
15078 verbose argv "C:\\Program Files\\nodejs\\node.exe" "C:\\Program Files\\nodejs\\node_modules\\npm\\bin\\npm-cli.js" "install" "-g" "particle-cli"
15079 verbose node v10.14.2
15080 verbose npm  v6.4.1
15081 error code ELIFECYCLE
15082 error errno 1
15083 error serialport@6.2.0 install: `prebuild-install || node-gyp rebuild`
15083 error Exit status 1
15084 error Failed at the serialport@6.2.0 install script.
15084 error This is probably not a problem with npm. There is likely additional logging output above.
15085 verbose exit [ 1, true ]

@jvanier, can you comment on that?

We know USB 3.0 ports can be tricky but mainly for use and not a installation blocker :confused:
The former could be worked around by using a USB 2.0 hub on the USB 3.0 port, but if you can’t even install that won’t help.

i remember ~ a year ago i had similar issues and so found this comment in the docs,
" If you must install particle-cli to the default global package location as the superuser, you have to use the --unsafe-perm flag to successfully install all dependencies: sudo npm install -g --unsafe-perm particle-cli."
so i used that command and it worked. maybe it helps here. also, the error about python path issues might indicate a inability to run install scripts.

1 Like

But for Windows it’s advised to not use npm but rather use the Installer.
If you had used npm before you should remove all installations of Particle CLI via npm uninstall -g particle-cli and also any local installations in other directories.

i sorta rationalized that using an admin command terminal in windows was similar to sudo in linux. i figured the --unsafe-perm flag was needed. one thing i did know is to uninstall the earlier installs cause my history with applications in windows taught me that. i noticed in the logs posted this line,
15064 verbose lifecycle serialport@6.2.0~install: unsafe-perm in lifecycle true
which reminded me of the flag which sent me to the docs. as far as using npm or installer you probably are correct now but last year there was a lot of the npm command stuff posted for windows.

1 Like

Uninstalling Particle CLI and running npm install -g particle-cli from administrator command window didn’t help.

Is there anything I should try, because Windows PCs without USB 2.0 may be rare so far, but more frequent in future? Or is my issue not related to missing USB 2.0?

@ZinggJM, I stopped using nodejs to install CLI on my Win10x64 laptop which has one USB3 and one USB2 connector. As @ScruffR said, I ONLY use the windows CLI installer and it works every time. Make sure to get the latest version.

1 Like

You may have noticed, that I tried exactly that. And it worked on one notebook, and now also on a second one. But it doesn’t work on my new MINIX. I only tried to use nodejs (npm) to get more information.

I still would like to know if this is related to missing USB 2.0 And your support should also care about that.

1 Like

@ZinggJM, no one who has responded to you, including the Elites, work for Particle. We are all volunteers. My laptop’s USB2 is ONLY used for a wireless mouse adapter. I run all my Particle devices from two USB3 powered hubs. As for the installation, it would seem like a permissions or firewall issue. I use Bitdefender AV which also has blocked the full installation until I “allowed” the installer to modify files. So it may be your AV, your Windows firewall, your router, your windows permissions, the folder you are installing from, etc. The serialport@6.2.0 error has popped up in the past with various systems. If you want assistance, I suggest you change your tone and your approach.

I understand that this sentence can be misunderstood. Sorry for that. I do not need help, as I have the workaround using one of the other notebooks. But I thought I should report what I think I have found out.

With the above sentence I meant there will be other users with new desktops or notebooks without USB 2.0 coming.

When I write in bold I try to emphasise the important points. I didn’t want to be rude.

@ZinggJM, I’m still not convinced that the issue is the USB3-only environment. However, it does beg for some testing by others who have similar testing if possible. Until others can duplicate the issue, it is not a “reportable” bug IMO. I will poke the Particle folks to see if they have any insights.

Thanks for reporting the issue @ZinggJM and thanks for helping to understand what’s going on @ScruffR and @peekay123

We’ll keep an eye out for additional users having issues with laptops without USB 2.0.

3 Likes

This error from npm is because you don’t have node-gyp configured so npm doesn’t know how to compile the binaries required for the particle-cli.

One way to fix this is documented here: https://github.com/nodejs/node-gyp#option-1

Install all the required tools and configurations using Microsoft’s windows-build-tools using npm install --global --production windows-build-tools from an elevated PowerShell or CMD.exe (run as Administrator).

I tried to install Particle CLI on a new small box PC (CSL 18012) with Windows 10 pro that has a USB 2.0 connector. Installation with Windows CLI Installer failed also. So USB 3.0 only is not the cause.

The installation was on a fresh installation of Windows 10 pro 1803, with Windows Defender only, pre-installed Antivirus SW uninstalled. I did run the installer with run as Administrator.

Is there any prerequisite for installing with Windows CLI installer, such as Java or python?

Do I need to allow internet access for some component in Windows Defender?
(With Arduino IDE I used to get a pop-up box requesting network access for Java).

You may see a Windows Defender SmartScreen warning when running the Windows CLI Installer if you are one of the first people to run the installer after a new release.

I didn’t get that.

Is there any prerequisite for installing Particle CLI with Windows CLI installer, such as Java or python?