Particle CLI not installing on Windows

I am trying to flash my xenon since it is not connecting to the internet, and I put it into listening mode.
I then tried to install the CLI, but it fails repeatedly. I tried running the installer as Administrator, and also updated npm and json. It still does not work. I first thought I might be running into errors because I was trying to install it over the companies network, and retried it over my own hotspot, but without succes. Does anyone know what the issue might be?

I get this error when I try to install the CLI via CMD:

C:\windows\system32>npm install -g particle-cli
[…] / rollbackFailedOptional: verb npm-session 7e30f2c7881e1666

@koenent, welcome to the Particle Community! For Windows, I highly recommend using the Windows CLI installer instead of going the npm route. It will install all the necessary pieces to get you going.

Thanks for your answer! Even though this seemed to be the best option I tried it several times and it failed repeatedly, that is why I tried the npm mode. It fails adding the dependencies, and closes the window by itself.

This is the error code I get when runnig the particle setup command in the command line as administrator

Microsoft Windows [Version 10.0.15063]
© 2017 Microsoft Corporation. Alle Rechte vorbehalten.

C:\windows\system32>particle setup
particle: Adding dependencies…
! Get dial tcp i/o timeout

! Error rebuilding packages.
! Try running again with GODE_DEBUG=info to see more output.
particle: Installing plugins…

! exec: “C:\Users\koenent\AppData\Local\particle\node-v8.15.0-windows-x64\bin\node.exe”: file does not exist
particle: Installing plugins (retrying)…
! Error installing package.
! Try running again with GODE_DEBUG=info to see more output.


@koenent, you cannot install or run the Particle installer from C:\windows\system32 directory as it is protected. I suggest you place the installer exe file in a user directory (eg. Documents) and re-run the installation. When you want to run the Particle CLI, run it from a similar directory, NOT C:\windows\system32.

@peekay123 , I tried what you suggested, but without succes, the cli was installed in the documents folder, but did not add the dependencies.

The last time I ran the installer I got this error:

@peekay123 I managed to solve the issue. I contacted my colleagues from my company, and they told me the problem was due to the local network blocking the download of several features. I uninstalled all the particle software and then reinstalled using my phone hotspot. That worked out great!! Thanks for your support!!

1 Like