Particle Cli not installing

I have node installed and it works fine. But when i run the command “npm install -g particle-cli” it gives off this error and this as well can anyone help

You could try this installer, which makes the whole process a lot easier:

So after i install this, i run the command once more and it should work?

tThat should install the CLI for you. You’ll see it once you open it :slight_smile:

Do i do all the packages?

Doesn’t hurt, but only selecting the CLI should suffice for, well, the CLI. But you might as well install the rest too.

didnt work. tried the particle setup command and installing particle cli and still not working

you still there?

Although I’m on here quite frequently, I do have a life outside of this forum :wink: I check every once in a while, so give it a bit of time.

What exactly “didn’t work”? You should install the CLI first, and then try the respective commands.

I guess you are on Windows 10 (judging by your screenshot).

The second screenshot complains about missing .NET Framework 2.0, since 10 only comes with 4.5, so it won’t harm to install 2.0 (as part of 3.5)

This is one resource about how-to (although only for Win10 preview), but there are others online too

should i just downgrade back to windows 8?

This should not be required, I’ve got Win 10 (Pro 64bit) on some machines and there it works too.

I have got .NET 3.5 installed and the installer @Moors7 suggested worked just fine.

I downgraded because i was tired of windows 10. Run the toolchain installer. now what?

What what?

If you ran the installer, you should have CLI installed - what more are you expecting?

if it did, then where do i do particle setup?

You should now be able to open a cmd and enter particle and see this

Welcome to the Particle Command line utility!
Version 1.8.16

Usage: particle <command_name> <arguments>
Common Commands:

    setup, list, call, get, device, identify, flash, subscribe
    compile, monitor, login, logout, help

Less Common Commands:
    token, cloud, config, function, keys, serial, udp, update
    variable, webhook, wireless

For more information Run: particle help <command_name>

Can you check your PATH?

You should at least have these entries in there

C:\Program Files\nodejs\;C:\Particle\dfu-util;C:\Users\XXXX\AppData\Roaming\npm;C:\Users\XXXX\AppData\Local\particle\bin

And the respective directories should exist :wink:

What do you get when you enter npm and npm version?

that doesnt exist

This is my path text: C:\Program Files (x86)\EasyPHP-DevServer-14.1VC11\binaries\php\php_runningversion;C:\ProgramData\Oracle\Java\javapath;C:\Program Files (x86)\AMD APP\bin\x86_64;C:\Program Files (x86)\AMD APP\bin\x86;%SystemRoot%\system32;%SystemRoot%;%SystemRoot%\System32\Wbem;%SYSTEMROOT%\System32\WindowsPowerShell\v1.0;C:\Program Files (x86)\Windows Live\Shared;C:\Program Files (x86)\ATI Technologies\ATI.ACE\Core-Static;C:\Program Files (x86)\Skype\Phone;C:\Program Files\Java\jdk1.8.0_60\bin;C:\Python27;C:\Program Files\nodejs;C:\Particle\Tools\Git\cmd;C:\Particle\Tools\NodeJS;C:\Particle\Tools\DFU-util;