Help Installing Particle CLI on Windows 10

@Erlend Were you ever able to get the Particle CLI up and working? I’ve been trying for 4 hours now and can’t get it to work. I’ve got Windows 10, and believe I’ve gone through all posts on the subject.

Have you given this a try, it has worked very nicely for me on Windows 10: Toolchain for Windows Installer

Thanks @Moors7, I’m now trying to follow mumblepins instructions, but I’m not sure what to do to get the “firmware”. This page seems very complicated and I’m not sure where to start:

Thanks you!

Unless you want to compile locally, there’s no need for the firmware. Using the installer should allow you to install the CLI and its dependencies. That was what you were after, correct?

Yes, I am trying to install the CLI :slight_smile: This is the window I followed with the installer. It took a total of about 10 minutes to complete:

Then, I opened the cmd “terminal” on my computer and typed in: npm install -g particle-cli
Then, I got similar long slew of errors again

The CLI should already be installed if the installer worked like it should, no need to install it again. Could you try running particle in your terminal?

Okay, I tried typing “particle” into my terminal and I got this result:

Could you check that directory to see if those files are present?