[SOLVED] Particle Login.. hangs in Cmd Prompt

Hello community,

I’m having trouble getting Particle CLI to run on my windows 10 machine.

After installing the Particle CLI, I try to run “Particle Login” but it keeps saying “particle: Installing plugins…”

Particle%20Login%20Delay

I thought it may be related to the npm warning. Here are the versions of node and npm on my machine.

Node%20and%20Npm%20version

Any thoughts on what could be keeping the Particle CLI from loading?

Thanks!

On Windows CLI should be installed via the CLI Installer
https://docs.particle.io/guide/tools-and-features/cli/photon/#using-windows
For Windows 10 make sure not to install the USB Serial drivers.

But when you have installed via npm I’d recommend uninstalling CLI from all locations and then reinstall with the installer. For future updates use particle update-cli instead of npm.

BTW, you should not run npm install from within Windows/system32. Rather put do that from a less sensitive directory - prefereably your user account directory.

Hi ScruffR,

Thanks for the tip. Just to check, what is the best way to unistall the current CLI? Would I be able to see it under add/remove programs or is there a terminal command which will do that?

Thanks!

If you installed via the installer, it will be visible in Add/Remove Programs
Otherwise you’d use npm uninstall -g particle-cli.
But if you previously used npm install without the -g or --global switch, you might have multiple instances of CLI on your machine, which you’d need to locate “manually” and remove from there via npm uninstall particle-cli or remove the complete “local” *node* folders.

1 Like

Thanks ScruffR.

I tried again with the windows installer, and was on a different internet connection and waited patiently. It all installed properly. I just needed to wait longer.

Thanks!

2 Likes