Will not complete setup via app [SOLVED]

@maf,

can you try upgrading OpenSSL? I have the recommendation here: Tutorial: Particle-cli on Windows [07 Jun 2015]

Let me know? :smile:

Alack alas, no luck with the latest openssl version. Same error messages as before. I know that a factory reset risks bricking the board, but would it restore a valid key or was the key corrupted when the board was originally factory flashed?

Yow,
maf

No no. I don’t think it does and there’s no point in factory resetting for now.

May i know what’s your issue to give more concrete advice?

The Photon board would not connect out of the box, and the cause seems to be corrupt encryption keys. I’ve followed the instructions to backup and re-create keys, but the commands fail with openssl errors. It seems that any command to retrieve keys from the device encounter problems with the header length/format. As yet, no luck in getting the board to connect to the cloud and register itself.

maf

@maf,

What is the status of the RGB led? Flashing cyan with occasional orange?

There’s a video at

Ok cool.

That’s a little trick to solve with your situation.

Here’s a dummy public keys file: https://dl.dropboxusercontent.com/u/36134145/particle/junk.pub.pem

Can you download and do a particle keys send DEVICEID junk.pub.pem. Be sure to replace it with the actual deviceID and once you do that, reset the Photon and it should work.

I did the above in DFU mode, then reset the board. No change in the LED behavior. After a ‘particle login’ and ‘particle serial wifi’ command, the board remains in the same state as before. I’m also seeing the same error messages when trying to back up the keys. It doesn’t look as though the corrupt keys were replaced.

maf

You dont need to be in DFU mode to run that command. That will simply send a public key to the :cloud:

Did you get something like successfully submitted a public key?

Yes, I got a “submitting public key…” message followed by “submitting public key succeeded!” Same message in DFU mode and setup mode. I also tried the command after the board was reset. No apparent change in behavior. Will the app recognize the board?

Ok so is it still blinking cyan with occasional orange?

Yes, same pattern as the video…

Ok

1 Like

OK, I do believe the board is now “breathing” (slow rise and fall of blue). Connect via USB or app?

@maf,

It sounds like you have breathing cyan (https://docs.particle.io/support/troubleshooting-support/photon/#led-colors-explained-) which means the device is successfully connected to the :cloud:

It doesn’t show up on the Particle app. How can I verify it is operating correctly?

You have the CLI right? Can you do a particle list?

That returns “No devices found.” Do I need to login and set wifi credentials in setup mode?

@maf,

I do suggest following the guide again but here’s what you can do for now:

  • press the SETUP button until the Photon blinks blue
  • Use the mobile app and go through the process of adding a new Photon.

I have a feeling you are using two different accounts since submitting a key via CLI would not have worked if the device is not claimed under the account in the first place.

In the long effort to recover the board, I claimed the device many times without success. I tried the mobile app and again, it failed in the fifth step where it tries to verify product ownership. Would unclaiming the id via USB clear up the conflict? I have only one account in the cloud, BTW.

maf