[SOLVED] Dfu-util: No DFU capable USB device available

I cannot seem to make my new particle core connect to my computer. dfu-util never sees it, and neither does the particle cli.

While in dfu-mode (blinking yellow):

$ dfu-util -l
dfu-util 0.9

Copyright 2005-2009 Weston Schmidt, Harald Welte and OpenMoko Inc.
Copyright 2010-2016 Tormod Volden and Stefan Schmidt
This program is Free Software and has ABSOLUTELY NO WARRANTY
Please report bugs to http://sourceforge.net/p/dfu-util/tickets/

Found Runtime: [05ac:8290] ver=0146, devnum=3, cfg=1, intf=5, path="20-8", alt=0, name="UNKNOWN", serial="UNKNOWN"

And while blinking blue:

$ particle setup
 _ __             _   _      _        
| '_ \  __ _ _ __| |_(_) ___| | ___ 
| |_) |/ _` | '__| __| |/ __| |/ _ \
|  __/| (_| | |  | |_| | (__| |  __/
|_|    \__,_|_|   \__|_|\___|_|\___|

> Setup is easy! Let's get started...
> It appears as though you are already logged in as martin@abstractpuzzle.com
? Would you like to use this account? Yes

! PROTIP: Hold the MODE/SETUP button on your device until it blinks blue!
! PROTIP: Please make sure you are connected to the internet. 

> No devices detected via USB.
? Would you like to scan for nearby Photons in Wi-Fi setup mode? Yes

! PROTIP: Wireless setup of Photons works like a wizard!
! PROTIP: We will automagically change the Wi-Fi network to which your computer is connected.
! PROTIP: You will lose your connection to the internet periodically.

> No nearby Photons detected. Try the `particle help` command for more information.
? Would you like to wait and monitor for Photons entering setup mode? No

> Ok, bye! Don't forget `particle help` if you're stuck! <3

This is a particle core, and I have worked with these before, but not this particular one. I’ve done a factory reset and tried both of these steps again. I do wonder if this has something to do with having to re-install node, and the particle cli. I had quite a bit of trouble getting both of those to work before I even got to this point.


Let me ping someone that might be able to help you. @tylercpeacock are you able to assist?


This does not match up with a Core. Are you using a Core or Photon?

Also, is the device in DFU mode?

Can you also try sudo dfu-util -l and see if the results changes?

I switched USB cables, and it works now. Gah! (Sorry!)