[SOLVED]Unable to connect to the Spark Cloud with Phone

With the Android APPI have no success to claim my Photon device. Connection to my WiFi gateway is working (Fritz!Box). Any blinking on the module is correct, but most of the time there is no success to be connected to the Cloud. Sometimes there will be success (2%), but then it hangs forever in the product verification. Via USB and terminal program I can read the device ID (decimal - long number, but cannot be used in online IDE account?) and I can also enter manually the WiFi connection (“w”), but finally after green blinking and changing to the next expected colour it doesn’t change to anything more (to be registered?). What shall I try next?

If you’ve got the CLI installed; Hold the SETUP button until it starts blinking blue rapidly, after which it enters Listening mode (blinking blue). Then, in the CLI, execute a particle identify. Copy the resulting ID for later. Following that, do a particle serial wifi and follow the steps. When that’s done, and the device is breathing cyan, do particle device add [ID] in which you paste the ID you copied earlier.
While you’re at it, place the device in DFU mode (blinking yellow), then issue a particle update. Place it in listening mode once more and do particle flash --usb tinker, which should place the default Tinker firmware back on there.

Give the above a try and let us know whether that worked for you?

Thank you for your response! As beginner I have tried before to read about the CLI installation:

I following this link: https://github.com/spark/particle-cli

Pressing the node.js links results into:

Below of node.js I have found:

“node-serialport currently does not install on node 4.0, so particle-cli will not install either. We are tracking the issues and will update particle-cli as soon as node-serialport is fixed.”

What is now the valid version and where I can get this version?

Pick the one for your system, 0.12.7 should work.

With the “new old” node.js version CLI is now working, but …

Yesterday I have tried to do the same with the terminal program with the ‘w’ command.
Finally it changed from “green” to a hectically cyan (?) blinking and this forever. Same now with the CLI.

Right, strange. Could you try the particle update and then retry?

Thank you again! But now I need all the DFU stuff, right?

@helios you should considering updating your firmware to 0.4.5 !

thanks @Moors7

1 Like

Correct. Put your device in DFU mode, then issue particle update through the CLI.

The guide mentioned by @corey should work, although you shouldn’t have to download the files, since the CLI already has them. particle update will automatically apply both updates. The steps to get DFU working are valid though, and the drivers should be installed accordingly.

1 Like

Because only the serial interface driver has been installed I go have …

1st used this tool …

… to get 2nd the follwing:

… and:

Next I have tried again:

It has changed automatically after updating from green to fast cyan blinking.
After a longer time I have pressed the reset button again, because no change in the fast cyan blinking.
After reset the device has sometimes red and some yellow/green blinking inside, but now after a longer time the same endless cyan blinking. In the MMI of my WiFi gateway I can see that the Photon is member of my network. Ping is working. How to proceed?

Alright, we’re making progress :smile:
Does the blinking look something like this?
If so, could you try these steps, you might have corrupted your keys somehow.

I would like to say after reset yes, but finally the high frequently cyan.
I will continue with “these steps” now and have success “cyan breathing is working” :smile:

1 Like

Finally all done found on “these steps” link:

particle login
particle identify
particle serial wifi (not required, because has been already o.k.)
particle device add ID

… with the result of:

Has been a hard work (for me) and I would prefere that the APP should work :smile:
I was buying this device to get fast the feeling that I can control the red LED via APP before digging into the DFU, wrong key and other hard core device problem stuff.

But finally I like to say thank you (@Moors7, @corey) for your near to online quality assistance, your support was excellent. I have tried to protocol everything - hopefully that other newbies with the same problem are getting the required information, too.

No I will continue with my simple RED LED stuff :smile:

1 Like

Sorry to hear that the initial experience wasn’t as great as it should’ve been, but I’m glad that it’s working like it should now. On the bright side, you’ve now got the proper tools installed along with the experience on how to use them, which will undoubtedly benefit you in the future.
Not wanting to disappoint you, but the onboard LED, the D7 one, is blue :wink: The RGB one can be made to change to any color you’d like though :smile:

Should you run into further issues, please, do not hesitate to ask. We’re here to help and have fun ::smile: