Will Boron work with Telus Cat M1 in Canada?


#41

@trickster when you do get it connected, make sure to set a really short keepalive time. The only time that has kept it consistently connected for me is 30s.


#42

so I follow the https://docs.particle.io/support/particle-devices-faq/electron-3rdparty-sims/#setting-up-a-3rd-party-sim-card-boron from the section Setting up a 3rd Party Sim Card Boron

right after the following commands:

particle compile boron 3rdPartySIM.cpp --saveTo firmware.bin --target 0.8.0-rc.27
particle flash --usb firmware.bin

the blue LED stays lit as per the instruction, so far so good…I am guessing my APN is set

then I issue the following command and from here things dont see to go as instructed
particle flash --usb tinker-0.8.0-rc.27-boron.bin

this completes successfully, the blue LED is now off…

and I put the Boron in Listen mode, which goes OK
I issue the following to identify the device ID, which seems good too…
particle identify

by this time, the unit is NOT breathing cyan…
I issue the following and the command fails
particle device add YOUR_DEVICE_ID << with my device id copied from previous command

Failed to Claim device: Device is not connected

what gives? and why wont it be breathing cyan…??

is it because of this firmware revision hybrid-0.8.0-rc.27-boron.bin ??

@natedog which firmware were you testing with on your Boron device?


#43

@trickster I’m using rc27. What did you use for your APN?


#44

m2m-east.telus.iot


#45

I used the android app for claiming my device, otherwise it seems we did everything else the same. :man_shrugging:t2:


#46

I had tried the app too on my android phone, I scanned the barcode and it failed to claim the device…


#47

I’m amazed at how complicated it seems to be to operate the Boron LTE in Canada. I’m loosing confidence in the product unless I can get support from particle on how to enable LTE on the Boron in Canada without spending the next month or so making it work. For instance, why the h… is the particle onboard sim not working on the Telus network and/or failbacking on the standard LTE network for testing purposes. How are we supposed to run some basic test or proof of concept on the product without a workable LTE product ? Folks at Particle, some hel is needed. Thanks


#48
  1. Because there currently is no contract negotiated between Telus and Particle for that.
  2. Because the cellular module is not capable of falling back - LTE is not the same as LTE Cat M1.
    https://docs.particle.io/datasheets/cellular/boron-datasheet/

#49

@pgauvin1, the product description for the Boron clearly shows:

Note: Particle’s MVNO will provide support for LTE M1 connectivity in the US upon initial release. Not in the region? Check out the Boron 2G/3G Kit. See the cellular FAQ for details.

@natedog was the first to be able to connect to LTE CAT-M1 in Canada using a 3rd party SIM from Telus while @trickster seems to be having issues. This tells me that LTE M1 is still not quite fully baked in Canada. Nonetheless, I hope that Particle is negotiating with “the big three” to make it possible to connect in Canada using the Particle SIM. In the meantime, I have been using the 2G/3G Boron without problems.


#50

its important to realize that cellular is hard…there are so many variables involved, and to ensure everything works well and smoothly for a final product means lots of hours burnt in coding, late night hours, blood, sweat and tears and some good luck!

thankfully that’s were Particle comes in, they make a lot of that seem so easy!!

as far as I know, the only operator Particle has a partnership with in Canada is with Rogers…and lofty Robbers, still don’t have LTE-M Cat1 in production yet despite promises like the following, end of 2018 has gone and no news of Cat1 rollout in Ontario yet…sadly Particle only has partnership with Rogers until now.

hoping they are working with Telus to get something going specifically for IoT application

so many people are confused by LTE for smartphones and LTE for IoT two very different animals!


#51

@natedog did you need to enter your credit card details even though you were using a 3rd party sim chip?

I got somewhere with claiming the Boron using the app but its informing me to add a cc in my console…


#52

:spark: already has my credit card info on file for a 3g electron SIM, so I didn’t need to.


#53

Success!!

I guess there was no LTE-M Cat1 in Niagara area where I was trying on the weekend

Breathing Cyan!! and I don’t have a cc added yet…


#54

@trickster
What are you using for your keepalive time?


#55

30seconds, and still doesn’t appear to be good enough!!


#56

Thanks for your answer