WiFi Extender Interference

Hi all,

I recently start using a WiFi extender (Totolink EX750) near my desktop because the wifi signal is really weak at my corner.

But my Photon and P1 cannot connect to the Internet after then. I can see they are trying blinking green fast. I tried putting them to the Safe Mode but still got the same issue. Then I unplugged my extender, everything works perfect again.

For a moment I almost updated the cc3000 driver but I guess it is because of the signal interference. So is there any way I could solve this problem running my WiFi extender?

Thank you very much!

Hi @codemonkeyboris

First off, the Photon and P1 do not use the TI CC3000 so updating that is not correct.

I read the install manual for the extender and it looks nice. I see that using the web-based setup, you can control the SSID names of the 2.4GHz and 5GHz networks such that they are different across the bands and even different from your base upstream SSID(s). I would try that, making sure that the extender uses a different SSID for the 2.4 and 5 GHz bands and that they are different from your main SSID.

Then you can clear the credentials in the Photon and try adding just the 2.4GHz SSID for the extender and see if it works. I believe it will. You can then further experiment with setting the 2.4GHz SSID back to being the same as your base upstream network and clear credentials and try that. I think that will most likely get you going since I think the problem might be related to the 5GHz band and the extender trying to migrate clients from 2.4 to 5 GHz, but if that doesn’t help, come back and ask for more help here.


Hi bko,

That makes a lot of sense. Thank you very much for the suggestion. I am gonna have a try.

1 Like