Using Workbench, can't flash device - token incorrect but

I have generated a new token in the CLI, and I have it, but where do I enter it into Workbench?

Why would you need a new token for Workbench?
Have you tried Ctrl+Shift+P
image

1 Like

I get this error when I try to flash it:

::: PUTTING DEVICE INFO DFU MODE

HTTP error 401 from https://api.particle.io/v1/devices/E-Tracker0 - The access token provided is invalid.

I’ve been using Workbench, using the same method to flash my devices for a long time with no issue, namely the little Lightning Flash symbol on the top right. But I haven’t used it for a couple months so something has changed, and it sounds like it wants a new token, on the basis that the old one expired maybe?
But I don’t know where to enter the token.

Have you tried Particle: Login?
You may need to first Particle: Logout and then login again.

BTW, neither for putting the device into DFU Mode nor for local building/flashing a token should be required.
Could it be that you are building in the cloud?

I’m not flashing locally. I am indeed trying to flash in the Cloud, using Workbench. Meaning, my device is in the field, with only cellular access, with good connectivity.

The issue was indeed re logging in. In the CLI, I did ‘particle login’ then entered email and pwd then it stopped giving the error on the token.