How to Cloud Flash a device marked "Development" inside a Product

In Particle Workbench, I cannot Cloud Flash a device that is marked as a “Development Device” inside a Product. I’m sure this is as-designed, but is there any way around it? I like to test my new firmware on devices that are in the field - they are not at my workstation. Here is the error I get when trying to perform a cloud flash within Workbench:

attempting to flash firmware to your device DEV-A3-0003
Failed to flash DEV-A3-0003: Permission Denied

I have a workaround, but it seems strange. I would add the deviceID to my Personal devices, so that it both exists in a Product and Personal. Then if I Cloud Flash it works.

is there any way around it?

sure, use the CLI directly:

  1. run Particle: Launch CLI
  2. in the terminal that launches, run particle cloud flash --help
  3. look for the explanation and example for the --product flag

don’t see it? run particle update-cli to grab the latest. hope it helps!

Ah, man! That worked beautifully. Thank you!

My fault for expecting it to work with the Workbench GUI or command palette. The CLI command was really easy to cloud flash.

Link to docs that I missed: https://docs.particle.io/reference/developer-tools/cli/#flashing-a-product-device

1 Like

That worked beautifully. Thank you!

great to hear!

that said, WB should probably do more to guide you here. i’ll keep it in mind for a future update. thanks for the report :pray::+1:

1 Like