USB Driver Setup on Windows 7 fails

For a Particle Photon, I downloaded and installed USB drivers: particle_drivers_6.1.0.68.exe
Installation ran without problems. (I am on Windows 7 Professional 64bit).
However, when I plugin my Photon into USB, I get the following three messages (translated from German):

  1. USB-connecting device: successful, may be used
  2. Photon Serial: failed
  3. Photon Control Interface: Driver was not found

I tried all combinations of reboot/manual installation, it did not help.
I also tried to manually remove hidden drivers, the problem remained the same:
The OS of the Photon is 1.0.1.

The only hint might be the message in the device manager for the ‘Photon Serial’: “Driver was not installed (Code 28)”.

What else can I do? I want to use serial debugging.

here is an thread somewhat related to your issue. the thing i found possibly relevant is the poster found that windows update would find/install an updated usb driver on the english ver. of win7 but would not find/install it on the german ver. of win7. you may want to read the thread. i post it so you can be aware.

i would think all necessary drivers would be in the particle usb package so there might be just some kind of conflict.

Thanks for your link, dkryder. Unfortunately, it did not help. The Particle Drivers are not of the WinUSB class. Besides, I found a laptop where the serial drivers work.
My working computer is really cluttered with software and drivers. Nirsoft’s USBDview displays 173 installed USB drivers. There was even one with the same device name as the Photon. Unfortunately, even removing this other driver did not help.
So now I am using two PCs, one for developing and one as a serial monitor…