Can't seem to install drivers for my Electron

First let me apologize if this has been covered before. I tried searching, but I can’t find a search box for this forum - honest.

When I plug my ParticleIO Electron in via USB it shows up in my device manager under “Other Devices” as “Electron”, but the device manager indicates that the drivers are not installed.

I ran node-v6.9.4-x64.msi
I ran “particle_drivers_6.1.0.51.exe” to install the drivers.
I ran “npm install -g particle-cli” from a command prompt.
I put the Electron in Listen mode (flashing blue), and plugged it into a USB port.

But no matter what I do, I keep getting…
"The drivers for this device are not installed. (Code 28)"
in device manager.

Any tips would be greatly appreciated.

Well I’ve made some progress by doing a manual install of dfu-util using Zadig_2.2.exe

Now “Photon DFU Mode” appears under “libusbK USB devices” when the Electron is in DFU mode. According to the docs that looks right.

But when it’s in listening mode I see “Electron” under “libusbK USB devices”. This is wrong according to the docs. Instead it should say something like “USB Serial Device (COM 4)” under “Ports (COM & LPT)”

So I think I’m getting closer - but not there yet. Any tips?

First things first:


What version Windows are you running?
Windows 10 won’t require serial drivers (DFU drivers are still needed tho’).
For versions < 10 you can also use Zadig to install the WinUSB drivers.

But usually the installer should have worked.
Maybe you need to uninstall the device drivers that are currently linked to the device via Device Manager and then reinstall the drivers.

D’OH! Thanks for pointing out the search feature. I can’t believe I didn’t see that.

I’m running Windows 7 professional.

For versions < 10 you can also use Zadig to install the WinUSB drivers.

Thanks. I just now tried that, but no luck. Not sure if I’m doing it right. When I run Zadig now I’m selecting “Photon DFU mode” and I can then select “WinUSB (v6.1.7600.16385)”. At that point I can either “Replace Driver” or "Install WCID Driver. I wouldn’t think I should replace the existing driver as the Photon DFU driver appears to be the one that’s working now.

Before I uninstall and attempt to re-install, can you tell me if I’m making the right selections in Zadig to install the WinUSB drivers?

Thanks.

For that your device is not allowed to be in DFU Mode. It needs to be in serial mode, which is essentially everything but DFU on a Photon.

Thanks. When I put the device in serial mode, can you tell me what selections to make in Zadig?

In serial/listening mode you don’t want to use the Zadig drivers (that’s for DFU mode). particle_drivers_6.1.0.51.exe should have installed the serial driver. If you see a Zadig driver when your Electron is in listening/serial mode please uninstall it and try “Searching for new hardware” again. Windows should install the correct driver.

@harrisonhjones, zadig also works for installing serial drivers when the standard way doesn’t work (as the OP indicated).

@spork, the drivers to use for that would be USB Serial (CDC)
But if you manage to install the Particle drivers, that would be the preferable way.

You can also use tools like 7zip to unpack the driver .exe and use the .cat/.inf files to update the driver “manually” via DevMgr.

1 Like

Thank you both so much for your patience! I Installed the “USB Serial (CDC)” driver, and now all is well in both modes. Woohoo! :smile:

1 Like