[SOLVED]Photon DFU Mode Driver failed for Electron setup

Hey there, fresh blood here. I can’t even get my device to flash over USB ;] I followed this guide from the electron setup page:

It seems like part of the problem might be that this guide was written specifically for the Proton and I’m trying to set up an electron…

The first time I tried to load the USB driver with Zadig it timed out and now I get this message when I try to load it:

Neither the --usb nor --serial flashing switch is working.

Any advice?

Well…it looks like I can’t delete this post but a PC restart fixed the issue…as one might expect :stuck_out_tongue:

3 Likes

No need to delete this - others might stumble across the same issue, and might find the hint useful.

2 Likes

I have the same problem. And restart do not help. When put device in DFU mode computer no detect device.

Computere detect device but when put in DFU mode and try to flash
Error writing firmware…No DFU device found

You may show a screenshot of your Device Manager (with the device visible) when the device is in DFU Mode.
Also try different USB cables and ports.

in DFU mode

Ohh GOD. After 10 restart finally zadig-2.3 install USB driver. Now i success flash photon finally. Now everthing is ok.

Everthing start when i used a code for temperature sensor and somethnig is going wrong.

I see you have double posted - which is frowned upon here
[SOLVED]Photon DFU Mode Driver failed for Electron setup
DFU mode and device not found

Here is final.
Now everything is OK.